No task to run...found

I re installed vscode, platformio extension and reload the project from source (tasmota)

When I go to terminal and run task… the system respond by “no task to run found”.
I don’t know what I can do to solve it…

The project is what I downloaded, platformio.ini at the root…

Many thanks for your help…

I ran into the lack of PlatformIO in VScode this morning. Yesterday everything was OK.
For a long time I could not understand what was the reason…
It turned out that the latest update PlatformIO 1.9.1 did not work in VSCode.
I downloaded the older version of PlatformIO 1.9.0 and everything returned to their places.
I hope the developers read this post and fix it.:face_with_monocle:

Sorry for the issue, just update extension to 1.9.2.


I have 1.9.3.

This project worked fine last I opened it. But, I’m guessing PIO and VSC have updated in the interim.

No clue what to do…

with platformio 1.10.0 happen the same task error, “No tasks to run found”. I tried reinstall all extensions but nothing. From console all works fine.

Provisional workaround:

I have the same error in PIO 1.10.0

Sure you’re not having the issue described and solved in PIO, VSC can't build, no tasks found?

1 Like