Newbie question regarding & with VSCode install

I’m not new to “coding”, but new to IDE’s. I barely know a bit on sketch creation with the Arduino IDE and attempting to learn C++ at an old age.

During the install of VSCode and PlatformIO, the later (evidence shows) tried connecting to via Python, failed due to my Malewarebytes blocking it as a Phishing attempt, tried a second time to and was also blocked as a Phishing attempt.

What is this about, why these “secretive” attempts to connect to external server storage and does this have anything to do with why PlatformIO doesn’t seem to load PlatformIO based ESP IDF code and libraries.

1 Like

At first glance this looks like it just uses one of the many servers in PlatformIO content distribution network (CDN) to download the needed packages for the project (such as platform-espressif32, framework-espidf, toolchain-xtensa-esp32.. etc).

Are things like

Downloadable normally?

Maybe @ivankravets can confirm?

1 Like

Oh yes actually this URL is even mentioned here

Thanks @maxgerhardt for your reply.

The PlatformIO install vectored me to these “CDN’s” soley related to it’s installation. This was long before my attempt to look at an ESP32 project code.

Surely, these espressif32 bits can be downloaded from other mirrors that are not Chinese. yes/no?

PlatformIO pulls dependencies (libraries, toolchains, etc) from its own CDN (content delivery network). Packages are mirrored to multiple data centers across the globe. PlatformIO picks the server nearest to you that has the best download speed. If one server is unavailable (or blocked by your firewall), it tries another.

@ivankravets, thank you confirming.

It’s not chinese, is central USA (hence usc) for example is in Europe (germany more precisely).

1 Like

My thanks for the US confirmation. My PlatformIO install is now complete.

Well, or so I thought…what do these ERRORs mean under Output in PlatformIO?

Resolving esp32doit-devkit-v1 dependencies…
Already up-to-date.
Updating metadata for the vscode IDE…
Error: Processing esp32doit-devkit-v1 (platform: espressif32; board: esp32doit-devkit-v1; framework: espidf)

Verbose mode can be enabled via -v, --verbose option
CONFIGURATION: Redirecting...
PLATFORM: Espressif 32 (6.3.2) > DOIT ESP32 DEVKIT V1
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (cmsis-dap) External (cmsis-dap, esp-bridge, esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)


  • framework-espidf @ 3.50002.230601 (5.0.2)
  • tool-cmake @ 3.16.4
  • tool-esptoolpy @ 1.40501.0 (4.5.1)
  • tool-idf @ 1.0.1
  • tool-mconf @ 1.4060000.20190628 (406.0.0)
  • tool-ninja @ 1.9.0
  • toolchain-esp32ulp @ 1.23500.220830 (2.35.0)
  • toolchain-xtensa-esp32 @ 11.2.0+2022r1

Error: Detected a whitespace character in project paths.

========================== [FAILED] Took 1.24 seconds ==========================

That’s a limitation of the ESP-IDF build system. You must change your project location to a path that has no spaces.

1 Like

@maxgerhardt thank you for that insight. That appears to have been the problem. My current project workspace states ‘no problems detected’ and all my libraries have lost their squiggles.