PlatformIO Community

New and confused 2

I just installed VCS, PlatformIO and NRF52.
I get this error message but can not understand what its telling me or how to fix it.

What have you clicked at to make that error appear? It appears on startup?

1 Like

All Blue links on that page shows the same error.
Just the error text is different.

Clicking on the link works for me and invokes my standard browser configured in Windows (Firefox). There’s a default browser set in your Windows 7 control panel right?

In VSCode -> Help -> Toggle Developer Tools -> Consoles are there any error messages logged after clicking the link?

Also, this feature isn’t really criticial… It just opens your web browser to that page. All the main PlatformIO functionality should be untouched by this.

This error shows up anywhere there is a web link.
The log file (after reinstalling VSC again):
console.ts:137 [Extension Host] runCommand platformio Array(1) Object
console.ts:137 [Extension Host] Found PIO Core 4.2.1
console.ts:137 [Extension Host] runCommand platformio Array(9) Object

I’m glad to hear that everything else should work, I did not know that.
Thanks

1 Like

Again this. Maybe temporarily setting it to IE or Firefox or Chrome fixes it? https://www.groovypost.com/howto/change-default-browser-windows-7/

1 Like

Could be a problem.
I do have 2 versions of FF installed. [ to keep past bookmarks separate ]

Well, look at that !

So does it help when you enable the HTTP and HTTPS protocols for one of the firefox browsers?

No, I am trying Segger Embedded Studio.

I’d be curious to know what happens if you open that link (http://platformio.org/platforms/nordicnrf52?utm_source=platformio) in your web browser… does it work for you on your system? It should redirect to the https version of the page, and show basically the same page you see in PIO Home.

This a bug in a recent release of Python Click package which we use https://github.com/pallets/click/issues/1501

We are going to release PIO Core 4.3 tomorrow which will ignore this broken version. A temporary solution is to open PlatformIO IDE Terminal and type

pip install "click<7.1"

Or, switch to the latest PIO Core 4.3-dev with pio upgrade --dev command.

1 Like

Yes, it does work.
I clicked on the link above and it displays the correct page.

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\Donald>pip install “click<7.1”
Collecting click<7.1
Using cached Click-7.0-py2.py3-none-any.whl (81 kB)
Installing collected packages: click
Successfully installed click-7.0

C:\Users\Donald>

Same error.

You need to close VSCode and kill all python.exe processes. This issue was fixed in upcoming PlatformIO Core 4.3.

I see by Prof Google, that “PlatformIO Core” is the CLI.
Does this mean a previous version of “PlatformIO Core” would not have this bug ?
Is this something I can install my self ?
How ?

Simplest option is to wait for a day or two, since it seems PlatformIO (PIO) v4.3 will drop shortly with a fix in place. Then you can upgrade to that either via the sidebar icon or the PIO Terminal. Otherwise, you’d need to roll back the CLI (which is the PIO core) to an indeterminate earlier version (indeterminate as I don’t know what version of the PIO core uses a version of the python Click package earlier than v7.1). That may not be so simple to do either, since you’d probably need to completely remove the currently installed version.

PlatformIO Core 4.3 is our! Please upgrade.

Sorry, I do not see how to do that.