PlatformIO Community

MSP430G2553 launchpad cannot upload - no USB FET was found

Hi
I’ve been using pio for Arduino using Debian sid, and it all works well.
However on my old MSP430G2553 launchpad board, I can compile but not upload, failing with the error " No USB FET was found"

I installed the mspdebug package, and can successfully control the board using the rf2500 driver with mspdebug - I just can’t upload using PIO.

Below is the output of an attempt:

Processing lpmsp430g2553 (platform: timsp430; board: lpmsp430g2553; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/timsp430/lpmsp430g2553.html
PLATFORM: TI MSP430 2.2.0 > TI LaunchPad MSP-EXP430G2553LP
HARDWARE: MSP430G2553 16MHz, 512B RAM, 16KB Flash
DEBUG: Current (mspdebug) On-board (mspdebug)
PACKAGES: 
 - framework-energiamsp430 1.10807.190926 (1.8.7) 
 - tool-dslite 1.80200.1400 (8.2.0) 
 - tool-mspdebug 1.2400.190926 (24.0) 
 - toolchain-timsp430 1.40603.190926 (4.6.3)
LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 18 compatible libraries
Scanning dependencies...
No dependencies
Building in release mode
Checking size .pio/build/lpmsp430g2553/firmware.elf
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [=         ]   7.0% (used 36 bytes from 512 bytes)
Flash: [=         ]   6.6% (used 1084 bytes from 16384 bytes)
Configuring upload protocol...
AVAILABLE: dslite
CURRENT: upload_protocol = dslite
Uploading .pio/build/lpmsp430g2553/firmware.elf
DSLite version 8.2.0.1400
Configuring Debugger (may take a few minutes on first launch)...
        Initializing Register Database...
        Initializing: MSP430
error: MSP430: Error initializing emulator: No USB FET was found
Failed: MSP430: Error initializing emulator: No USB FET was found

Maybe some pointers at MSP430 upload failed "No unused FET found." help? Does manually using a newer version of dslite help?

I did see your previous help on that topic a few days ago. So I went looking for drivers on TI’s site, and attempted to install MSP430_FET_Drivers 1_0_1_1 - this however fails to install, its missing a udev rule file and I’ve asked about that on the TI forums as well.

I have tried using the DSLite from the latest Energia (9.2.0.1793-e1) and also from the latest version of TI’s Uniflash (10.1.0.2076) - both failed with the same error.

I’ve also tried installing the latest ccs from TI, & Energia in the hope that maybe some config is missing in PIO, but I get the same error from both of those tools when they run DSLite.

I’m lost. All I know is that mspdebug rf2500 can talk to the board, but DSLite cannot find it.

Does running sudo pio run -t upload make a difference? What’s the output apprears when starting dmesg -w and pluging in the device?