MSP430: Problem with mspdebug


#1

Hi

Ive been using Platformio on linux for some time, recently I switched to another linux setup and installed everything clean.

I am using MSP430 boards (G2553) and compiling the code works completely as planned. But from the IDE (I have tried both VScode and Atom) I cannot upload the code on the board. It always stops with :

_"/home/username/.platformio/packages/tool-mspdebug/mspdebug: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory"

I cannot debug where it goes wrong but when I use the terminal, go to the directory of my project (with platformio.ini) and type

“pio run -e lpmsp430g2553 -t upload”

it runs as planned. Compiles and uploads directly to my launchpad board.

Anybody with a clue as how this can be corrected ?

kind regards
Cor


#2

Additionally. When I call the “pio run -e lpmsp430g2553 -t upload” from the terminal inside Atom or VScode it also fails with the same error.

regards
Cor


#3

What is your Linux distro? It seems that IDE starts with another PATH in comparison to your temrinal. Do you use default shell?


#4

Hello Ivan,

I am on Linux mint 18.3 (64bit). The working pio run was not run from a shell inside the IDE, I just went to a normal linux-terminal from the directory where platformio.ini is avaiable

To provide even more info, I inspected the mspdebug script that is installed

#!/bin/bash
export LD_LIBRARY_PATH="dirname "$0""
exec -a “$0” “dirname "$0"/mspdebug_bin” “$@”

When I inspect variable $@ I see that the section prog firmware.hex is not surrounded with "- brackets.

Cor


#5

Does your project contain a space in a project path?


#6

No, I used an example to test things after my normal projects only would compile but not upload.
FYI heres a full project-folderpath
/home/corbee/Documents/PlatformIO/Projects/180311-153440-energia-blink


#7

Ive tried something else. I setup a virtualbox with a standard Ubuntu 17.10 iso and … got the same problems. I also created a virtualbox with a 32bit Lubuntu setup and in that setup I was able to upload.

regards
Cor


#8

When I execute pio device list from within Vscode or Atom I get no devices listed at all. When I run the same command outside vscode/atom it shows my device. It looks as if the environment of vscode and atom are shielded