PlatformIO Community

Monitor_filters = time - timestamp does not show

Dear All,
I use MacOS 12.4 arm, vs code 1.69.1, PlatformIO Core 6.1.2a3 Home 3.4.2, Espressif 32 5.0.0.
The platformio.ini file contains:

[env:nodemcu-32s]
platform = espressif32
board = nodemcu-32s
framework = espidf
monitor_speed = 115200
upload_speed = 230400
monitor_filters = 
	time
	colorize
monitor_raw = yes

The timestamp does not appear in monitor window.
I tried pio upgrade --dev but it did not solve trouble.

Could you please help me about it?

Thank you in advance.
Best regards
zox1

And when you remove that?

1 Like

Dear maxgerhard,

Thank you for quick answer.

When I remove monitor raw = yes the timestamp appear.
In this case the unreadable characters appear and colorize does not work. I use monitor_raw = yes to avoid unreadable characters on monitor.
monitor_encoding¶ has not helped me. I use default UTF-8.

Best regards
zox1

Per docs, that only colorizes the sent and received data in different colors, but doesn’t enable the ANSI color codes that the ESP-IDF sends to work.

The problem I’m seeing is that raw mode turns off all transformations, so time and colorize are ignored.

Based on pio device monitor — PlatformIO latest documentation you might try the filters default, time or printable, time.

1 Like

Dear maxgerhard,

Thank you for quick answer.
As you suggested I have tested some monitor_filters setting. Now my setting is:
monitor_filters =
time
direct
esp32_exception_decoder
and it works fine.

Thank you very much for your help and support.

Best regards
zox1