Missing libraries in framework-arduinoespressif32

Hello everyone :slight_smile:

i’m currently testing the esp32 with arduino sketches under Ubuntu 16.04 and my example is compilable in the arduino ide (1.8.2), but the ide is… barbaric. That’s why i wanted to give platformIO a try and it looks really good (autocomplete yaay).

Problem is: i’m not able to compile the same project under platformIO, the error msgs look like this:

Fatal error: can’t create .pioenvs/node32s/lib/ESPmDNS/ESPmDNS.o: No such file or directory
*** [.pioenvs/node32s/lib/ESPmDNS/ESPmDNS.o] Error 1

i looked into the path where your version of arduino esp32 framework is and some libs are missing which are available in the arduino-esp32 libraries:

Libraries that are missing:

  • ArduinoOTA X
  • FS X
  • Preferences
  • SD X
  • SD_MMC
  • SimpleBLE
  • Update X
  • WiFiClientSecure

the libraries marked with an X seem to be needed to compile my project :frowning:
Is there a way to add these missing libraries? I tried to just copy&paste, but that sadly won’t work,
files are now found but tons of compiling errors?
Do you guys have a solution/workaround? Until then it looks like i am punished with the barbaric arduino ide -_-


I have the same problem, please help.

Do you use stage version of esp32 for Arduino?

P.S: I’ve just updated development platform for ESP32. Please pio update.

1 Like

It works, but now throw "ArduinoOTA.cpp:7:21: fatal error: ESPmDNS.h: No such file or directory"
Resolved, adding “lib_ldf_mode = deep” (withouts quotes) to platformio.ini.
Thank you very much for the help.


it compiles wonderful now with the updated libraries, thanks for the fast help :slight_smile:
But i ran into another problem while trying to upload via ota:

i added the line upload_port =
in my platformio.ini (ip is correct)
and it seems like he tries to open a file/tty named ‘’ ?
Here is the error msg:

serial.serialutil.SerialException: [Errno 2] could not open port [Errno 2] No such file or directory: ‘’
*** [upload] Error 1

and here is the complete ini, hope it helps:
platform = espressif32
board = hornbill32dev
framework = arduino
upload_port =

It works on arduino IDE, did i miss to add some configuration somewhere?


We are working on this issue