Missing bottom toolbar

I’ve been using PlatformIO for a few months and all was working fine, but now I don’t see the bottom toolbar with the icons for compile, upload, etc.

I’ve searched prior entries and responses to similar problem, but haven’t found one that restores the toolbar.


You seem to have some weird workspace setup. You have 3 workspace open at once and you have .code-workspace files in your src – these are not generated by PlatformIO. Where do they come from? Any third-party extensions installed which might conflict here?

First you should right-click on every folder in your work space and remove them from the workspace. Then use the left-side PlatformIO Icon to open PIO Home and re-open the project you want to work on.

What does it look like then?

For reference, in my VSCode it looks like


Um… since the statusbar is completely missing from the looks of things… have you checked it’s not turned off?



Thanks for the quick response. Obviously I still have much to learn about Platformio.

I only see the one workspace - Radio_Mailbox_Master Workspace. Each of the subheadings (folders?) under the this Workspace are cloned GITHUB repositories for arduino programs (radio_mailbox_red, radio_mailbox_green, radio_mailbox_Yun_yellow- i deleted the 4th respository).

I have been modifying each of these programs, compiling, uploading, testing, updating GITHUB successfully until now when I no longer see the blue toolbar that you have at the bottom of your screen, which allows me to compile & upload to arduino boards and sync Github.

I am not aware of any conflicts and haven’t loaded any new components to PIO that I’m aware of.

I did as you suggested and then opened an old project I found at PIO home ( I couldn’t find the projects I was working on at PIO home, but they are in a folder on my PC).

Here is what it looks like now. Still no blue toolbar at the bottom of the screen.

Am I supposed to have one workspace for each program/project?

Bingo! That fixed it. Thanks very much.


I built these projects by copying and modifying the files from my first project so could that have caused the .code-workspace files in my src?

Is there a way to get those folders that were not projects built via PIO Home to show up there?