Marlin 2, TMC26x file name to long to Build?

I’m struggling with trying to get marlin 2 on my new printer. I keep getting an error about the TMC library, I think, and not sure what to do. I downloaded Marlin again but when I tried to compile using VS Code it kept giving me an error trying to unpack a file. I then installed ATOM and downloaded another copy of Marlin and starting getting an error also in the TMC26x file. I tried updating the library and then tried to revert to an older version both without success. It seems like it has something to do with platformio because it happened in VS and Atom but I’m new to all of this so I know the issue is with my lack of knowledge. Hell, I struggle with just trying to use an online forum but if anyone could at least point me in the right direction, I would be very appreciative.

Processing STM32F4 (platform: ststm32; framework: arduino; board: disco_f407vg)
Verbose mode can be enabled via `-v, --verbose` option
HARDWARE: STM32F407VGT6 168MHz, 192KB RAM, 1MB Flash
DEBUG: Current (stlink) On-board (stlink) External (blackmagic, jlink)
PACKAGES: framework-arduinoststm32 3.10601.190716 (1.6.1), toolchain-gccarmnoneeabi 1.70201.0 (7.2.1)

Converting Marlin.ino

LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
LibraryManager: Installing c1921b4
Using cache: C:\Users\Zo\.platformio\.cache\8c\f244bfa38b7bfff5e9042f5d9f9f5c8c


WindowsError: [Error 206] The filename or extension is too long: 'C:\\Users\\ZO\\Desktop\\3d Printer\\Files\\0_3D_Printers\\SKR_Pro\\MArlin_A\\Marlin-bugfix-2.0.x\\.piolibdeps\\STM32F4\\_tmp_installing-ohrrji-package\\TMC26XStepper-c1921b4856a5ef4b659b661b8c


  File "C:\Users\ZO\.platformio\penv\lib\site-packages\platformio\builder\", line 126:


  File "C:\Users\ZO\.platformio\packages\tool-scons\script\..\engine\SCons\Script\", line 541:

    return _SConscript(self.fs, *files, **subst_kw)

  File "C:\Users\ZO\.platformio\packages\tool-scons\script\..\engine\SCons\Script\", line 250:

    exec _file_ in call_stack[-1].globals

  File "C:\Users\ZO\.platformio\platforms\ststm32\builder\", line 91:
target_elf = env.BuildProgram()

  File "C:\Users\ZO\.platformio\packages\tool-scons\script\..\engine\SCons\", line 224:

    return self.method(*nargs, **kwargs)

  File "C:\Users\ZO\.platformio\penv\lib\site-packages\platformio\builder\tools\", line 122:


  File "C:\Users\ZO\.platformio\penv\lib\site-packages\platformio\builder\tools\", line 47:

    project_lib_builder = env.ConfigureProjectLibBuilder()

  File "C:\Users\ZO\.platformio\packages\tool-scons\script\..\engine\SCons\", line 224:

    return self.method(*nargs, **kwargs)

  File "C:\Users\ZO\.platformio\penv\lib\site-packages\platformio\builder\tools\", line 1046:


  File "C:\Users\ZO\.platformio\penv\lib\site-packages\platformio\builder\tools\", line 881:


  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\managers\", line 353:


  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\managers\", line 724:


  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\managers\", line 506:

    self.unpack(dlpath, tmp_dir)

  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\managers\", line 214:

    return fu.unpack(dest_dir, with_progress=with_progress)

  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\", line 118:

    self._unpacker.extract_item(item, dest_dir)

  File "c:\users\ZO\.platformio\penv\lib\site-packages\platformio\", line 38:

    self._afo.extract(item, dest_dir)
File "C:\Users\ZO\.platformio\python27\Lib\", line 1031:

    return self._extract_member(member, path, pwd)

  File "C:\Users\ZO\.platformio\python27\Lib\", line 1082:


 [FAILED] Took 7.55 seconds

That’s one long filename right there. Can you move your PIO project from C:\Users\ZO\Desktop\3d Printer\Files\0_3D_Printers\SKR_Pro\MArlin_A\Marlin-bugfix-2.0.x\ to like C:\Marlin?


lol, That makes so much sense that it hurts. I knew the problem had to be me. I kept thinking it was talking about the TMC26xc-1921b4856a5ef4b659b661b8cb5dd56f3075e57 file. Thank you so much for the quick reply, I can finally move forward on this build.

1 Like