Mac Atmel ICE broken (again)

I’m on Montery (12.3.1) and I have a project that I need to modify. It’s worked fine previously, and I think even on the Mac although I had to load an unsigned “kext” to get things moving.

I usually work on Linux or Windows (at a pinch) but I’m stuck with the Mac for now.

This is what I THINK used to work.

upload_protocol = atmelice_isp
upload_port = /dev/cu.usbserial-14130
upload_flags =

But now AVRDude is bitching complaining about the USB port. I think someone had a fix for this but (as is typical) that seems to have gone missing in the mess of the Internet and vagaries of search engines.

avrdude: jtag3_open_common(): JTAGICE3/EDBG port names must start with "usb"

I’ve found the serial upload utterly hopeless on these cheap Chinese clones but right now it’s all I have and the only way I can make them work (at all) is to use an ICE programmer.

I’m migrating to ESP32 an other boards (like the Pi Pico and Teensy) but I need this thing uploaded to a Uno because it is deigned for a specific LCD HAT.

I’m stuck!

Replace this with -Pusb. Does it make a change?

Same error Max, but thanks for the quick response!

What’s the avrdude invocation line when you execute the project task Advanced → Verbose Upload?