PlatformIO Community

LiquidMenu library installation

Hello,

I am trying to install the library LiquidMenu however I get the error:
.pio/libdeps/nanoatmega328new/LiquidMenu/src/LiquidMenu.h:53:10: fatal error: LiquidCrystal.h: No such file or directory

I can fix this error by updating the line in LiquidMenu.h as below:
#include <…/…/LiquidCrystal/LiquidCrystal.h>

However I was wondering if I have installed the library correctly as I would rather not need to modify the downloaded library source code…?

Also I have tried all the different lib_ldf_mode settings such as ‘deep+’ but that did not help.

Thanks,
Alex.

Good question – it looks like you found a bug. I’m trying this with

[env:uno]
platform = atmelavr
board = uno
framework = arduino
; select liquidcrystal library (1) instead of the I2C version (2)
build_flags = -DLIQUIDMENU_LIBRARY=1
lib_deps =
   vase7u/LiquidMenu@^1.6.0
   fmalpartida/LiquidCrystal@^1.5.0
   Wire
lib_ldf_mode = deep+

and the dependency is still not recognized.

Dependency Graph
|-- <LiquidMenu> 1.6.0
|-- <LiquidCrystal> 1.5.0
|   |-- <Wire> 1.0
|-- <Wire> 1.0

(LiquidMenu should have LiquidCrystal as a sub-dependency).

This is likely due to the way the libary is included with the conditionals.

This sort of defines seems to overwhelm the detection logic.

I will open a bug about this.

1 Like

This is now tracked in https://github.com/platformio/platformio-core/issues/4152.

1 Like

Thank you for your quick response, good to know I installed the library correctly as I am quite new to platformio coming from arduino ide.