Linter not working correctly?

I’ve noticed that the Linter will show errors in header files when the project builds without errors.

In my case, this is due to the fact that I don’t put #include “Arduino.h” in my headers, opting instead to always include the Arduino.h file first in the .cpp files.

  1. Can someone fix the Linter to correctly follow the compiler’s order-of-includes? (Meaning it would start processing on the .cpp units first, and process .h files as they are included?)
  2. Is there a way I can disable the Linter for header files?