Librarys in ./lib cant include default header files: No such file or directory

Hi, I’m working on a pretty big arduino project with a wemos d1 mini.
I need almost all the pins but pin 15 isn’t working as output with the newest version from esp8266 audio. I also can’t change the version to 1.7 where it’s said to work because platformio complains that theres no compatible version for windows amd64.

So I tried to manually download the library Esp8266audio version 1.7.0 and put it in the ./lib folder. When I compile the project I get the error
lib\ESP8266Audio-1.7.0\src\AudioFileSourceICYStream.h:28:12: fatal error: ESP8266HTTPClient.h: No such file or directory

Is there something I have to add to the platform.ini? Thansk for yor help.`

Full platformio.ini? Did you try adding lib_ldf_mode = deep+?

Oh here it is `
; PlatformIO Project Configuration File
; Build options: build flags, source filter
; Upload options: custom upload port, speed and extra flags
; Library options: dependencies, extra library storages
; Advanced options: extra scripting
; Please visit documentation for the other options and examples
; Redirecting...

platform = espressif8266
board = d1_mini
board_build.f_cpu = 160000000L
monitor_speed = 115200
framework = arduino
lib_deps =
adafruit/Adafruit NeoPixel@^1.11.0

Ok, tried it, works.

Thanks for your quick help.