Library version specification in platformio broken?

I worked on a project for the last time on August 20th. Today I wanted to start work again, but without a change it doesn’t build anymore. Currently I’m on Core 4.1.0b1

> Executing task: platformio run --environment esp12e <

Processing esp12e (platform: espressif8266; board: esp12e; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 8266 2.2.3 > Espressif ESP8266 ESP-12E
HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
PACKAGES: toolchain-xtensa 2.40802.190218 (4.8.2), tool-esptool 1.413.0 (4.13), tool-esptoolpy 1.20600.0 (2.6.0), framework-arduinoespressif8266 2.20502.0 (2.5.2)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
LibraryManager: Installing id=727 @ ~3.0.1
UndefinedPackageVersion: Could not find a version that satisfies the requirement '~3.0.1' for your system 'linux_x86_64':
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/builder/", line 145:
  File "/home/flurl/.platformio/packages/tool-scons/script/../engine/SCons/Script/", line 541:
    return _SConscript(self.fs, *files, **subst_kw)
  File "/home/flurl/.platformio/packages/tool-scons/script/../engine/SCons/Script/", line 250:
    exec _file_ in call_stack[-1].globals
  File "/home/flurl/.platformio/platforms/espressif8266/builder/", line 203:
    target_elf = env.BuildProgram()
  File "/home/flurl/.platformio/packages/tool-scons/script/../engine/SCons/", line 224:
    return self.method(*nargs, **kwargs)
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/builder/tools/", line 129:
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/builder/tools/", line 47:
    project_lib_builder = env.ConfigureProjectLibBuilder()
  File "/home/flurl/.platformio/packages/tool-scons/script/../engine/SCons/", line 224:
    return self.method(*nargs, **kwargs)
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/builder/tools/", line 1070:
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/builder/tools/", line 901:
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/managers/", line 368:
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/managers/", line 700:
    pkg_dir = self._install_from_piorepo(name, requirements)
  File "/home/flurl/.platformio/penv/local/lib/python2.7/site-packages/platformio/managers/", line 207:
    requirements or "latest", util.get_systype()
============================================================================= [FAILED] Took 0.35 seconds =============================================================================

Environment    Status    Duration
-------------  --------  ------------
esp12e         FAILED    00:00:00.351
nodemcuv2      IGNORED
======================================================================= 1 failed, 0 succeeded in 00:00:00.351 =======================================================================
The terminal process terminated with exit code: 1

My platformio.ini:

lib_deps_external =
#   ArduinoJson
#   ESPAsyncTCP
#   ESP Async WebServer
#   flurl's FSBrowserNG
#   NtpClientLib
#   Time
#   ===Project dependencies===
#   Servo
#    883@~1.1.4

monitor_speed = 115200
platform = espressif8266
board = esp12e
framework = arduino
lib_deps =

monitor_speed = 115200
platform = espressif8266
board = nodemcuv2
framework = arduino
lib_deps =

Obviously the library manager fails to find a suitable version for id 727 (NtpClientLib). According to PlatformIO Registry the latest version is labled 3.0.1-beta and indeed changing the version string in platformio.ini to 727@~3.0.1-beta solves the issue.

My question is now, what is the intended behaviour? Was it broken before, when it accepted the version without the “-beta” suffix or is it broken now and should I report a bug?

I’d have downgraded PIO to find the release causing that behavioural change, but couldn’t figure out how to downgrade.

Beside that, could someone explain, why the error message reads

UndefinedPackageVersion: Could not find a version that satisfies the requirement '~3.0.1' for your system 'linux_x86_64':

Shouldn’t it be looking for a version for the platform and/or the framework?