PlatformIO Community

Library updates ignored in registry

Hello Forum,
can anybody help me with a library not being update in the library registry of platformIo?
I registered the library some days ago and the first two changes of the library got picked up.
Yet the registry did not see my library.json and used the arduino specifc library.properties instead (which resulted in no examples being listed and other details missing). Since a day later it still did not work, I delete the library.properties from the git repo and tried to resubmit the library (it seems there is no way to unregister a library anyway).
No two days passed and the library is still not being updated, the registry still shows the link to the library.properties which of course now results in a 404.
Can anybody update my library manuall and switch to the library.json file please?
#7368 ESP-StepperMotor-Server
https://raw.githubusercontent.com/pkerspe/ESP-StepperMotor-Server/master/library.json

thanks a lot in advance

@ivankravets Bet you’re thinking LibraryAPIv2 can’t come soon enough! :stuck_out_tongue: :wink: Modification of library manifest or delete 'n reload asked for above.

1 Like

It looks like it works now? https://platformio.org/lib/show/7368/ESP-StepperMotor-Server

1 Like

Looks good, thanks a lot!

1 Like