Library installation error & JSONDecode error

I searched for library SSD1306_minimal under Libraries but it wasn’t in the Registry do I had to download it. I downloaded from Github, unzipped it and put the files in folder Document/PlatformIO/Projects/<project_name>/.pio/libdeps/digispark-tiny/SSD1306_minimal and added a line in platformio.ini: “lib_deps = kirknorthrop/SSD1306_minimal@^1.0.0”. I still have squiggly lines under #include <SSD1306_minimal> so what’s missing?

I tried to build to see what other errors would crop up and there is a JSONDecodeError which I have no clue what to do with.


    // Script and wiring found here....
ATTiny P2-> oLed SCL
ATTiny P0-> oLed SDA
ATTiny GND-> oLed GND
ATTiny 5V-> oLed VCC
#include <SSD1306_minimal.h>
#include <avr/pgmspace.h>

#include <TinyWireM.h>
#include <USI_TWI_Master.h>
#define DEG "xa7" "C"

#define DEG "xa7" "C"

SSD1306_Mini oled; // Declare the OLED object

void splash() {
oled.clear(); // Clears the display

oled.cursorTo(0, 0); // x:0, y:0
oled.printString(" DuinoKit Fun");

oled.cursorTo(0, 10); // x:0, y:23
oled.printString("With the ATTiny85!");

//oled.cursorTo(0, 20); // x:0, y:46
//oled.printString(" DuinoKit Tiny!");

oled.cursorTo(0, 21); // x:0, y:69
oled.printString(" Coming Soon");

oled.cursorTo(0,31 ); // x:0, y:69
oled.printString("with YOUR support!");

void setup() {
oled.init(0x3C); // Initializes the display to the specified address
oled.clear(); // Clears the display
delay(1000); // Delay for 1 second
splash(); // Write something to the display (refer to the splash() method

void loop() {

Build output:

    > Executing task in folder ATTiny85_OLED: C:\Users\hans\.platformio\penv\Scripts\platformio.exe run <

Processing digispark-tiny (platform: atmelavr; board: digispark-tiny; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Atmel AVR (3.3.0) > Digispark USB
HARDWARE: ATTINY85 16MHz, 512B RAM, 5.87KB Flash
DEBUG: Current (simavr) On-board (simavr)
 - framework-arduino-avr-digistump 1.7.2
 - toolchain-atmelavr 1.70300.191015 (7.3.0)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
JSONDecodeError: Expecting ',' delimiter: line 1 column 109 (char 108):
  File "C:\Users\hans\.platformio\penv\Lib\site-packages\platformio\builder\", line 178:
  File "C:\Users\hans\.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\", line 591:
    return _SConscript(self.fs, *files, **subst_kw)
  File "C:\Users\hans\.platformio\packages\tool-scons\scons-local-4.1.0\SCons\Script\", line 280:
    exec(compile(scriptdata, scriptname, 'exec'), call_stack[-1].globals)
  File "C:\Users\hans\.platformio\platforms\atmelavr\builder\", line 162:
    target_elf = env.BuildProgram()
  File "C:\Users\hans\.platformio\packages\tool-scons\scons-local-4.1.0\SCons\", line 658:
    return self.method(*nargs, **kwargs)
  File "C:\Users\hans\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 62:
  File "C:\Users\hans\.platformio\packages\tool-scons\scons-local-4.1.0\SCons\", line 658:
    return self.method(*nargs, **kwargs)
  File "C:\Users\hans\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 141:
    project_lib_builder = env.ConfigureProjectLibBuilder()
  File "C:\Users\hans\.platformio\packages\tool-scons\scons-local-4.1.0\SCons\", line 658:
    return self.method(*nargs, **kwargs)
  File "C:\Users\hans\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 1062:
  File "C:\Users\hans\.platformio\penv\Lib\site-packages\platformio\builder\tools\", line 886:
    if lm.get_package(spec):
  File "c:\users\hans\.platformio\penv\lib\site-packages\platformio\package\manager\", line 236:
    for pkg in self.get_installed():
  File "c:\users\hans\.platformio\penv\lib\site-packages\platformio\package\manager\", line 209:
    pkg = PackageItem(pkg_dir)
  File "c:\users\hans\.platformio\penv\lib\site-packages\platformio\package\", line 405:
    self.metadata = self.load_meta()
  File "c:\users\hans\.platformio\penv\lib\site-packages\platformio\package\", line 440:
    return PackageMetaData.load(manifest_path)
  File "c:\users\hans\.platformio\penv\lib\site-packages\platformio\package\", line 391:
    data = json.load(fp)
  File "C:\Users\hans\.platformio\python3\lib\json\", line 293:
    return loads(,
  File "C:\Users\hans\.platformio\python3\lib\json\", line 346:
    return _default_decoder.decode(s)
  File "C:\Users\hans\.platformio\python3\lib\json\", line 337:
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "C:\Users\hans\.platformio\python3\lib\json\", line 353:
    obj, end = self.scan_once(s, idx)
====================================================== [FAILED] Took 4.64 seconds ======================================================


platform = atmelavr
board = digispark-tiny
framework = arduino
lib_deps =

.pio/libdeps is for the automatically downloaded libraries which is considered a temporary directory, you should put the library in the lib/ folder of the project, then use lib_deps = <folder name of the library>, then do a intellisense rebuild (Ctrl+Shift+P _> Rebuild IntelliSense).

I tried in platform.ini with two ways of including the library:



and none fo them works.
Then there’s this problem with JSONDecodeError: . Could there be a corrupt file somewhere?