Libraries refusing to add again

Because it makes this life suck, I have to complain about doing everything right and still failing to get libraries to attach.

AsyncTCP is in .ini. I used the Github address. It’s correct.

I used your stupid utility to add it to my project, and it still doesn’t work.

It’s demoralizing. I’ve been avoiding this for a week, and I can’t start.
Libraries as a thing is something that has to be fixed. It doesn’t work. You can’t have an open source universe built on this unreliable nonsense where files are everywhere.

It is entirely possible that the github repo is in an incompatible format. I don’t know as you have not shown us theplatformio.ini file, nor mentioned whch board etc.

If you go here: PlatformIO Registry

You will find a number of libraries for different platforms. Pick the one for you, possibly this one:

There are instructions on installing.

I recommend always searching for a library that is known to PlatformIO, rather than randomly picking one off github. There’s usually plenty available with examples and/or instructions etc.


If you have reproducable error, I’m sure a bug can be traced down. But for that we need that reproducable example.

Again, I used the pio install function, and it didn’t work.


platform = espressif8266

board = esp12e

framework = arduino

lib_deps = 




me-no-dev is copied from the library page offered by PIO.

Looks correct. What compilation errors did you get?


HOW. Declaring Arduino as a library will certainly blow things up when it’s already the framework… what “library” is it supposed to fetch there?

Built-in libraries shouldn’t be declared here but with just a #include <WiFi.h> in the main file.

I like the “add to project” feature in the Libraries utility. It has worked for me at least once. But BME280 is making me crazy now.

I will stop adding Arduino to lib_deps. WiFi is “Built in”? And is that <> or “”?

I deleted both from Lib_deps in PIO, and here they are again, and again PIO won’t admit it.

I’m wondering why you are using the github link when the BME280 library is available to install. Add adafruit/Adafruit BME280 Library to your lib_deps.

You can search for the ability to install libraries correctly at A professional collaborative platform for embedded development · PlatformIO where the correct installation instructions are given – either to install separately; or to add to lib_deps.

In general, compiler supplied headers, or those that are subsequently installed into the system location, use <> while your own, or others in this project location, ie, lib_deps and/or pio lib install, use "".

Run a clean from VSCode. That should get rid. If not, just delete the .pio folder in the project, then build again. However, even though the removed libraries are present, they are not used by the code, so will not be linked to the final executable.

Libraries are compiled once and reused, unless you change the library source files. So only the first compile will build new libraries but you need a clean to get rid of removed libraries.