PlatformIO Community

Libraries not found / rebuild C++ index option not listed

Hi,

I’m running VSCode 1.39.2 with PlatformIO 1.9.2 (I’ve tried downgrading to 1.8.3 - same luck) working with the STM32F1 platform.

I’ve installed a library (RF24) thru the PlatformIO library manager. I’ve tried both the global and the local installation. In each case the library got downloaded and copied under:
c:\users\myuser.platformio\packages\framework-arduinostm32-maple\STM32F1\libraries\RF24_ID4523 (for the global install)
and/or
C:\Users\myuser\Documents\platformio\Projects\myproject.pio\libdeps\genericSTM32F103CB\RF24_ID2647 (for the application specific install)

Within each of these folders I get the RF24.h, RF24.cpp, etc.

In both cases a #include on my main.cpp file will not find the RF24 library. Compilation give a fatal error for the missing library.

After reading posts of the last two days it’s suggested to run a C++ rebuild index, but on my Command Pallette the C++ rebuild index doesn’t show up (I only have the option of the intellisense index rebuild).

All the other libraries that were installed with the default PlatformIO setup are there and available, all under the same path where my new RF24 library has been downloaded to. The only one not showing up is the RF24 that I installed thru the library manager.

Any way to add that library manually to the libreary finder? Any reason why C++ Index rebuild doesn’t show up?

Appreaciate any help. Thanks,

That’s exactly the same thing.

As the documentation says, can you add lib_deps = RF24 to the platformio.ini? If this does not work, post the entire output of the compilation here or to pastebin.com with the full platformio.ini and code