Lib not found with last versión Core change? Home change? Framework?

I’ve been working for the last year in a project with Windows 10, VisualCodeStudio, Platformio, ESP32 framework without problems but the last week I can´t link the project. The error is that the linker can´t find

-lUsers .platformiopackagesframework-espidfcomponentsxtensaesp32libhal

I have tried to downgrade the platformio version but it dosen´t works

I can see several versión at VSC extension manager but I dont know how it relation with Core and Home

The only way I can link my project works is using a old copy of the folders .platformio and .vcode, and when I start VSC, the platformio start to update and I can´t found the way to avoid this , for that I need work without internet connection

I think it is a wrong working way to allow that a development environment uptodat without ask if you want to do…

I’ve seen this type of error several times now, and they all comie down to using an old version of platform-espressif32 with a newer PlatformIO core. Several users report the issue is solved by a reinstallation of PlatformIO (remove ~/.platformio and restart VSCode). See Xtensa-esp32-elf/bin/ld.exe : Cannot find library.

Thanks for you help. I’ll tried it.

That didn’t work for me.


And Linker fails after PlatformIO update ESP32 - #11 by trichl?