Lib_deps Not Recognizing Header File

I am using CLion and the PlatformIO plugin with a microbit v2 board. I am just trying to get started on some basic LED blinking and followed the directions on the PlatformIO docs. I tried following the PlatformIO CLion docs to get started and it seemed to build and upload fine, but I did not notice any changes on the board or any blinking.
This example used was for Arduino but I thought microbitv2 was arduino as well and should have worked.

Since I didn’t notice any blinking from the CLion example, I tried pulling in a basic microbitv2 sample from here

However, this fails to build because it is not recognizing the Microbit.h header. I have tried
#include "MicroBit.h"
#include <MicroBit.h>

This is the library I’m trying to pull in, here is my lib_deps which matches

platform = nordicnrf52
board = bbcmicrobit_v2
framework = arduino
lib_deps = lancaster-university/microbit

I have also done Tools → PlatformIO → Re-Init like som posts suggested, but it is still failing.

What am I doing wrong? I’m just trying to get off the ground.

In firmwares for the Arduino framework you don’t implement main(), you implement setup() and loop()`.

This is not an Arduino library, but an mbed-os one.

Do you want to use Arduino or mbed-os?

I see, I think the framework = arduino was added when creating the project when I chose the microbit v2 board. When I look at the PlatformIO board docs, it looks like only Arduino and Zephyr RTOS are supported for this board. So that means I can’t use PlatformIO with an mbed-os framwork, correct?

I don’t mind using Arduino, but I’m not sure how to program this board in an Arduino framework since all those examples linked above are mbed-os. Does PlatformIO support any way for me to build those examples in that framework using the micro:bit V2 board?

Also from your previous response, I understand now the lib_deps documentation states that the compatibility defaults to soft, which will check compatibility with framework. Since as you mentioned, the library I was trying to pull in was mbed-os and my build framework was Arduino, it would not meet this compatibility requirement and would not pull in that header file.