Just trying to import my project! does not see my libraries!

I’m confused on what the proper procedure for importing the libraries I was using in the Arduino IDE as well if I’m even setting my project up correctly. HELP! :frowning:

When I click ‘import project’ from PIO home, I select my board(Espressif ESP32 Dev Module), I click the check box for it to use the installed libraries from the Arduino IDE, select my project then click import. All the code imports fine, i guess? but it never seems to get my libraries! I’ve tried putting them into the ‘project/lib’ folder but no luck. I’ve looked at the guide but don’t really understand how to setup my libraries with the IDE! I’m sure this is completely user error but gosh I’m just trying to import a simple project that I’ve been working on in an attempt to streamline my code and hopefully be more productive in a proper IDE. I really wish this would be more simple!


Have you tried

lib_deps = 
	Adafruit MQTT Library
  • where is the reactive_common.h? Must be in either include or src

  • rebuilding the intellisense after a successful compilation

  • does it actually compile?


I’ve fixed the reactive_common issue. Didn’t even notice it didn’t grab my header file :frowning:

But now I think I’ve started in the right direction of getting my libraries, but now I’ve run into this issue.

This is an issue with the library suddenly requiring a not-yet released beta version of the Arduino-ESP32 core, see Unable to compile for ESP32 board · Issue #104 · plerup/espsoftwareserial · GitHub. (Needs 1.0.3 beta but PIO only supports latest stable, which is 1.0.2.

Two different ways for fixing it:

  • roll back the library version for EspSoftwareSerial, meaning in your platformio.ini in the lib_deps declaration, instead of saying EspSoftwareSerial say EspSoftwareSerial@5.0.4 (see release history https://github.com/plerup/espsoftwareserial/commits/master/library.json). Preferably check the version of the lilbrary you have installed in your Arduino IDE and use this version number here
  • use the most recent beta Arduino ESP32 Core by saying
platform_packages = framework-arduinoespressif32 @ https://github.com/espressif/arduino-esp32.git#1.0.3-rc1

in the platformio.ini.

1 Like