PlatformIO Community

Just published library -- framework problems

I have, finally, published a PlatformIO library AVRmillis which is intended for use on the atmelavr platform but without a framework. It published fine with the library.json containing framework * and framework none etc, hence I’m up to version 1.0.2! (link to library A professional collaborative platform for embedded development · PlatformIO )

When I try and use the library, I get this error:

LDF Modes: Finder ~ chain, Compatibility ~ soft
Library Manager: Installing normandunbar/AVRmillis @ ^1.0.2
Warning! Could not find the package with 'normandunbar/AVRmillis @ ^1.0.2' requirements for your system 'linux_i686'

My library.json file is as follows:

{
  "name": "AVRmillis",
  "version": "1.0.2",
  "description": "This is a library for PlatformIO which allows anyone not using the Arduino framework, to write code which has access to Arduino-a-like millis() and micros() functions. The Arduino framework already has those functions built in, so this library is not suitable for use with that framework. The library has been tested on Arduino Uno, Duemilanove and Nano boards using the Atmega328P microcontroller. The library creates a class named AVR_millis, and a global object named AVRmillis through which the functions are accessed. See the readme.md file for full details.",
  "keywords": "millis, micros",
  "repository":
  {
    "type": "git",
    "url": "https://github.com/NormanDunbar/AVRmillis"
  },
  "authors":
  [
    {
      "name": "Norman Dunbar",
      "email": "norman@dunbar-it.co.uk",
      "url": "http://www.dunbar-it.co.uk/contact-us/",
      "maintainer": true
    }
  ],
  "license": "MIT",
  "homepage": "https://github.com/NormanDunbar/AVRmillis",
  "frameworks": "*",
  "platforms": "atmelavr"
}

I have tried with "frameworks":"none" as well, but the same occurred. What is the setting for frameworks when there’s no actual framework required.

This is my first library specifically for PlatformIO, and I’m rather flummoxed to say the least!

Cheers,
Norm.

I can’t reproduce that.

C:\Users\Max\temp\lib_test_ci>pio lib install "normandunbar/AVRmillis @ ^1.0.2"
Library Storage: C:\Users\Max\temp\lib_test_ci\.pio\libdeps\uno
Library Manager: Installing normandunbar/AVRmillis @ ^1.0.2
Library Manager: AVRmillis @ 1.0.2 has been installed!

You probably tested it a time where it was released on the webpage but not fully internally distributed between all CDNs of PlatformIO, giving you a “this package does not exist” response.

Ok, thanks Max. I did wait for the email saying it had been processed. I’ll try again tomorrow.

Cheers,
Norm.

Tested again just now. Worked a treat.

Cheers,
Norm.