JLINK 'waiting for GDB connection' very slow

When debuging with a Segger JLINK and ardvino mkr1010, connection to GDB takes about 60 sec!
If I do the same with ardvino IDE 2.0, the connection is instantaneous.
May be the parameters given to arm-none-eabi-gdb.exe are not the same with platformIO?
Who knows how to check these parameters? Any idea on what is causing the 60 sec wait?
Here is a screenshot of Segger and log on ardvino IDE


Open a CLI and use pio upgrade --dev and retry debugging. Is it still slow in PlatformIO?

I upgrade but still very slow.
The debug console gives:

Pretty sure you’re running into the 60sec timeout programmed in

Meaning PlatformIO can’t recognize the ready pattern of the JLink server correctly.

You can try to adapt the debug_server_ready_pattern.

Ohterwise, please report to Issues · platformio/platformio-core · GitHub with your exact platformio.ini.

Yes, 60 sec what I see.
I try the following pattern but no change

framework = arduino
debug_tool = jlink
debug_server =  C:/Program Files (x86)/SEGGER/JLink/JLinkGDBServer

debug_server_ready_pattern = ^.\*Waiting.\*

PlatformIO can’t read the output of GUI program, you must use the CLI version… Use JLinkGDBServerCL.exe instead of JLinkGDBServer. Without any debug_server_ready_pattern.

Also if you wanted to use one you should not create a new env: for it, but add the option to the envrionment you’re using. (But first do per above).

1 Like

Great, it’s now working perfectly with the CLI version!
Thanks a lot