JLINK Debugging Error

Hello all, I hope you are doing well as you receive this post.

I have been trying to learn how to use different debugging hardware and have been successful at using the ST-LINK/V2/some of its clones. I assumed the setup for both JLINK and STLINK would be very similar, but apparently they are a bit different. I followed the documentation as I thought it should be followed but I received this error message:

I am unsure what to do here considering I had to nothing with TCP/IP with a hardware debugger. And I also had this window pop up:


This is my current platformio.ini file config:


I just am confused about what to even do with IP, and since I do not know what to put in the box I have a feeling that this is the reason I am receiving errors. Any suggestions would be gratefully appreciated! Thank you!

Seems like a driver error to me. PlatformIO per the output above will try to use the native JLinkExe / JLinkGDBServerCLI to try to connect to the JLink. For that, the native JLink drivers (and not e.g. the WinUSB drivers) need to be installed.

What does the JLink show up as in the device manager? Have yuu tried installed the official drivers from SEGGER - The Embedded Experts - Downloads - J-Link / J-Trace?

1 Like

This worked, I was thinking that maybe I needed driver but because the document did not show the link to that site, I assumed it was unnecessary. Just wondering, is the core_dir function I have in my platformio.ini file necessary then? I assumed that would be what fixes my driver issue at first.

I would not recommend directing the PlatformIO core directory, it won’t fix driver issues.