Intellisense not working


I have installed VS Code and the PlatformIO extension - nothing else.
When I write code for esp32 the intellisense is showing too much.
For example it show “deepSleep” as an available function for “Serial” which makes no sense - see picture.
I have rebuild intellisense index and made a complete uninstall/install - same problem.
What to do ?

What other extensions are instaled in VSCode?

PlatformIO and the required C/C++ from MS


I’m unable to reproduce your problem. When I type “Serial”, wait for the IntelliSense and select the Serial object via the arrows, then press dot, I get the recommendations

and no deepSleep() in there – just really all the functions from Serial and the base class Print and Stream.

Try and open a CLI and do a pio upgrade --dev and pio platform update espressif32 to update the core and ESP32 platform, then rebuild the Intellisense again (Ctrl+Shift+P → Rebuild…) Also double-check that you’ve selected the correct project and environment.

If it still doesn’t work for you then, it’s a bug in Microsoft’s C/C++ extension for you that needs to be reported according to Issues · microsoft/vscode-cpptools · GitHub.

Sorry for sorta hijacking this thread but I’m also facing an Intellisense (?)-problem. It worked fine until a few weeks ago but since then Intellisense seems not to be willing to do ANY code-assist. So variables are coloured white and I’m unable to jump to any functions. Variable-content is also not shown.

I’m also working with VSC + ESP32 + Arduino. Already tried:

Got several projects active. Having said this: it happens across all projects.
Already tried to re-install platformio and MS’ Intellisense. But nothing changed :frowning:

Any suggestions?
Many thanks in advance.

What extensions are installed in VSCode? Just PlatformIO and C/C++ by Microsoft, right?

What’s the content of the .vscode/c_cpp_properties.json file?

Does the project build?

No, it’s filesize, GitLens, openHAB and Perl, too. However, I installed some and tested, but I’ve been deleting them meanwhile. Another thing to mention: a few weeks ago I had an issue, that some errors (sorry, don’t know anymore the error-msg). After a restart, Platformio didn’t appear anymore. However, was finally able to escape that by de- and re-installing MS’ Intellisense along with Platformio. After that it was fine, but now the new problem came up. Temperarily MS’ extension-pack was also installed but I removed it. So doesn’t seem to be the issue.

It’s not there. There’s just argv.json + extensions-folder.

Yes, that’s flawless. I’m just missing “code-assistance”. It looks a bit like it’s just disabled but I don’t know where to look at :woman_shrugging:

Don’t know if that matters: it’s running on a mac (mac os 15.15.7).

Im starting to feel like a n00b, as I don’t know what I could possibly have done wrong :joy:

Well that’s a major issue then. In VSCode, can you press Ctrl+Shift+P -> Rebuild IntelliSense? Does the .vscode/c_cpp_properties.json appear then?


It’s really strange. It was there and I clicked on it. Then I had to reload VSC und re-install IntelliSense + Platformio (but maybe because I previously deinstalled it).
However, now “Rebuild IntelliSense” is no longer selectable.

Additionaly, there’s a warning originating from c_cpp_properties.json stating that from arduino-esp32-framework there’s some “nimble-stuff” missing.

Hmm, looked at my homefolder. Probably it’s stored anywhere else?


This issue should be already fixed per Update framework-arduinoespressif32 package with hotfixes · Issue #508 · platformio/platform-espressif32 · GitHub. Try and remove the C:\Users\<user>\.platformio\packages\framework-arduinoespressif32 and C:\Users\<user>\.platformio\.cache folders and rebuild the project – it should pull the latest package version that has the fix.

But anyways, that’s just a warning that can be ignored.

Are you able to build project with PlatformIO now? Is the c_cpp_properties.json file there?

I’m still able to build but the file’s not there :woman_shrugging:

Disable all extensions but

, restart VSCode, and re-execute

Since you can build via PlatformIO that command should be available again.

Same issue.

My project(s) generate the intellisense anymore. I’ve tried everything…

I’ve disabled all extensions other than C++ and platform io.

I’ve deleted the .platformio directory and re-downloaded everything.

My project builds fine for both ESP32 and SAMD (mkrzero), but intellisense does not work.


And you sure sure the right project is active with the project environment switcher? What is the .vscode/c_cpp_properties.json of the project and what are the IntellISense errors showing up?

tnks that is great suggestion. it works.