Installed library not found

Hello everyone.
I’m a newbie to PlatformIO, but enjoying it so far.
I usually manage to google solutions with ease, but this time it’s proving different. I am trying to use pedvide’s ADC library (GitHub - pedvide/ADC: Teensy 4/3.x/LC ADC implementation), so I installed it using the PlatformIO’s library manager to my project, successfully I’d say as I can see it in libdeps\teensy31\Teensy_ADC, and the PlatformIO.ini contains the entry " lib_deps = pedvide/Teensy_ADC@^9.1.0 ". The includes on my files are these:

  #include <trapezoidal.h>
  #include <pins.h>


  #include <pins.h>


   #include <ADC.h>
   #include <ADC_util.h>
   #include <trapezoidal.h>

ADC.h and ADC_util.h both belong to the aforementioned library. When I try to compile the code i get the error (complete log below): lib\pins/pins.h:16:17: fatal error: ADC.h: No such file or directory
I have tried to reinstall the library, update PlatformIO, place the library on the libs folder and a few more things unsuccessfully. One thing I tried, in particular, was adding " lib_ldf_mode = chain+ " to the platformio.ini file. In this case, the compiler seemed to find the files, however it started to find duplicate definitions of some of the library’s code. Can anyone help me?
Best regards, Tiago

Dependency Graph
|-- <Teensy_ADC> 9.1.0
|--< comms> 
|--< pins> 
|   |-- <Teensy_ADC> 9.1.0
|   |-- < trapezoidal>
|   |   |-- < comms>
|-- < trapezoidal>
|   |-- < comms>
Building in release mode
Compiling .pio\build\teensy31\src\main.cpp.o
Compiling .pio\build\teensy31\libfed\Teensy_ADC\ADC.cpp.o
Compiling .pio\build\teensy31\libfed\Teensy_ADC\ADC_Module.cpp.o
Compiling .pio\build\teensy31\libfed\Teensy_ADC\AnalogBufferDMA.cpp.o
Compiling .pio\build\teensy31\libfb0\comms\comms.cpp.o
Compiling .pio\build\teensy31\lib38a\trapezoidal\trapezoidal.cpp.o
In file included from lib\trapezoidal\trapezoidal.h:15:0,
                 from lib\trapezoidal\trapezoidal.cpp:11:
lib\pins/pins.h:16:17: fatal error: ADC.h: No such file or directory