PlatformIO Community

In VSC Task Window always popping up: "Error: No handler found"


#41

Xaxa! Worked for me as well. I didn’t have anything additional installed, yet i had the same error. I disabled file icons altogether, restarted an re-enabled them. Error is gone. For now.


#42

My current working theory is that it’s VSCode being utterly stupid! :laughing:

More to the point… I have for instance a workspace with several different project folders in it… with code that compiles on different boards… ESP8266, AVR, STM8, whatever… that doesn’t seem to really matter. If when I open VSCode and simply build the project that was still open from when I closed VSCode, no error. If I open the main.cpp from another project, and build that… error pops up, and follow me around like a lost dog, even on the project that was re-opened when I started VSCode. If I then restart VSCode, same thing happens… so regardless of what project I was last in, when I first open VSCode, as long as I don’t change the project… all is good in the world of VSCode! :open_mouth:

i.e., work on tft_thinkspeak, close VSCode, reopen it, build, no error. Switch to tracerWifi… error rears it’s ugly head… retry tft_thingspeak, error there… go to tracerWifi again… error still there… restart VSCode, tracerWifi re-opens, builds without error, switch to tft_thinkgspeak… error re-appears… completely bonkers, this is! :black_joker:

Still no extensions other than PlatformIO + C++ enabled.

image


#43

Disabling Material Theme seems to solve the problem.


#44

I never installed this.


#45

I was wrong. What solved the problem is the fact that VSCode was relaunched. But this works only for a short time. After a while, the problem comes back again.


#46

Updated

The VSCode issue #68486 has been fixed by Microsoft team. You can switch to Insider Build or wait for upcoming VSCode 1.32.


It seems that it is VSCode bug, we have just reported it

This problem is not linked with other extensions. It’s very easy to reproduce it, just modify platformio.ini when IDE has started and try to run any tasks.

We can’t fix this issue on our side, sorry :frowning: The only working solution is to restart VSCode or run “VSCode > View > Command Palette… > Reload Window”.


#47

Looks like there may be a fix on the way, scheduled for this months build! :slight_smile:


#48

The current version of VSC/insiders has it fixed. 1.32


#49

hi do you know when this will be released?


#50

The insiders version is released. The regular version is usually monthly, but they tend to wait on significant changes.

Either way, using the current version will not prevent anything from happening. It’s just an annoyance to some. It never really bothered me.


#51

I switched to the Insiders build and it is much better without that popup :slight_smile: It will be great when this gets rolled out to the non-Insiders builds. I’d expect this to be sometime in March as they normally update once a month.


#52

They are so close to the final release. See https://github.com/Microsoft/vscode/milestone/86

According to https://github.com/Microsoft/vscode-docs/blob/vnext/release-notes/v1_32.md it should be released in the next 2 days.


#53

I pretty much use the insiders release all the time. The two versions hold their own settings so there is no conflict. As your observation, the insiders is updated more often.

The only downside before the users version was it had to do a system wide install. That is no longer the case anymore as the package is installed with user only permissions required.


#54

VSCode v1.32 is out, and not an ‘Error: No handler found’ to be seen! :slight_smile:


#55

I praise the Lord that this super annoying bug finally disappeared…


#56

I updated mine (VSC) today. No popups.