PlatformIO Community

In VSC Task Window always popping up: "Error: No handler found"


#21

I should probably have been clearer :open_mouth: AVR / Arduino, and ESP8266 Arduino, the latter is not throwing errors, the former is. :wink:


#22

STM32 mbed - also throwing errors.


#23

Same problem here… even if it is harmless, it’s annoying, have to close the popup to read the build results.

PlatformIO Version: 2.0.0 Home 3.6.4 Core
VSCode Version: 1.31.1 (1.31.1)
macOS Mojave 10.14.3
Framework: mbed
Platform: STM32 4.6.0
Board: NUCLEO_F446RE


#24

That worked for me:

Remove all folders from workspace
Remove all extension, and after removing each one, restarting VSCode
Reload extensions
Reopen folders on workspace


#25

This seemed to work for me, as well. Thanks for the suggestion!


#26

Remove (deinstall) extensions, or deactivate?


#27

Seems to work here, too!
Thank you very much for this highly efficient workaround.
I did not deinstall extensions, just disabled/enabled them, including platformio.

[Edit: was not sustainable, error returned after a while]


#28

The error is back :frowning:


#29

Guys, I’m here. How to reproduce this issue? I can’t :frowning: Do you use the latest 1.31.1 release?

What is your list of extensions? Maybe, another extension causes this issue? Could you try to disable all extensions and keep only PlatformIO + C/C++ by Microsoft? This is actually the one extension on the which we depend.


#30

v1.31.1 (user setup) on Windows 10

Still did not find out yet how to reproduce it.
Tried the workaround above, error disappeared, but reappeared after a few build.
Maybe it’s not platformio dependent, but caused by some other VSC extension.


#31

I thought it was only AVR platform related, but one of my ESP8266 projects just started doing this also. I went through and disabled all but the PlatformIO and C/C++ extensions and it went away (VSCODE 1.31.1 + debian linux x64). I selectively turned them back on again, and it seems so far that it is the vscode-icons extension that is triggering the error to come back (robertohuertasm.vscode-icons) - which makes sense as it seemed to rear it’s head vscode-icons had just updated IIRC. My other extensions are markdown related + GitLens + Microsoft Python extension. I’ll update again if it re-surfaces.


#32

Could you try ti disable other extensions and find out which produces this error?


#33

I’m not using this extension (means it is not listed under active extensions), but i do have the error.


#34

I disabled all extensions except PIO and C/C++ and the problem went away, very odd… I went through and enabled Doxygen, Clang-Format and Python and the problem is still gone. The only extensions left are java related and they are not needed in my current workspace. So I’m not sure which plugin it might have been causing the issue. It is very puzzling and I wish that VSC would say which task/extension is causing the error…


#35

Very strange one this… I re-enabled vscode-icons, restarted the IDE, and it seemed to still be gone. So I switched workspaces, and it was fine, and then I opened the second project in that workspace and voila, it was playing up again. I can now entirely consistently get it switching from the main.cpp from one project to the main.cpp in another, both open as tabs… with no other extensions at all enabled, and the IDE restarted to make sure it’s a clean slate. :open_mouth:


#36

It’s really annoying. Hope someone finds the root cause soon.
What about the link to the VSC github repo i posted above? Looks like this is the routine which at the end throws the error.


#37

It’s now happening to me. I have been working on the same project for weeks. I switched to another one and the popups started.

To clarify what happened before was those messages just appeared in my compile window. Now it’s a VSC popup.


#38

I’m seeing the same thing here, Win 10 Enterprise, latest VSCode and PIO installed, happens on every PIO operation and is pretty annoying.


#39

Did you install other 3rd party extensions? Could you share an example of platformio.ini?


#40

I was also getting these messages consistently. Disabled Material Icon Theme 3.6.3 (due to earlier comments) and restarted. Problem vanished. Enabled Material Icon Theme and restarted - it was still gone. ???