In VSC, Platformio keeps initializing


Out of the blue (at least for me) I can’t run PlatformIO anymore. VSC keeps initializing PlatformIO core. I have uninstalled it, reinstalled it, but always the same result, keeps initializing. It happens with a fresh project or with a project which i have been worling on for weeks. Your advice is much appreciated.

I run OSX Sonoma 14.4.1

Uninstalling is not a real uninstall - it only removes the VS-Code plugin.

  • Exit VS-Code
  • Delete the .platformio/penv folder in the home directory
  • Start VS Code
  • Wait until the PlatformIO installation is finished.
  • Restart VS Code when you are prompted to do so

I don’t know OSX but under Windows the PlatformIO directory is located under C:\Users\<username>\.platformio

Thank you for your replay. HOwever, this is MacOS and totally different. There is nog such a directory, whereas with Windows there is. I have both machines and can compare.

There must be somewhere a “.platformio/penv” folder.
I have asked a friend with a Mac and I am currently waiting for the answer.
In the meantime, can you search for a folder called “penv”?

I got a reply. It’s the same location as on Windows:
It is a hidden folder!

Thank you Sivar, found it and working again…

1 Like