IDE upload only works once. Window counter doesn't stop


First of all, great product, and kudos for everyone that contributed.

I’m running the platform ide on Arch linux with the latest versions of node (v6.4.0), electron (v1.3.3) and IDE version 1.4.0

So far so good.

Still if I create a simple Arduino program, and I press Upload, then a command line window opens, the upload process starts and concludes sucessufully. Still the window has a counter in seconds that doesn’t stop even after the upload sucess.

From this point I can’t upload anything again on the IDE, without closing it and opening it again.

Any ideas?

What is Atom version?

atom -v
Atom : 1.9.8
Electron: 1.3.3
Chrome : 52.0.2743.82
Node : 6.3.0

Not sure if this help, but it seems that the issue is with atom-builder.

I’m using the latest version of atom-build: 0.65.0

There is an error now that appears on the IDE: emitter.prependListener is not a function.

Atom has a lot of issues with Arch Linux. See article Platformio – Primal Cortex's Weblog

Could you report this issue here?

Well the issue is this one: atom-build runs forever · Issue #441 · noseglid/atom-build · GitHub
But it was closed due to inactivity…

Instaling atom from AUR (atom-editor-bin) instead of atom from the main repos solved everything.

Are you an author of Platformio – Primal Cortex's Weblog ? :blush:

yep, I am. This issue was the only one I couldn’t solve since it was deep inside nodejs base code on the children_process.

The aur atom-editor-bin uses much older self contained chrome, electron and nodejs versions, without clashing with the main packages, so it works out of the box with platformio ide :slight_smile:

OOOOOOhhhh my goodness.
Thank you for the tip with atom-editor-bin.
It finally works again.
I even once got a debug session from Ivan. Nearly everthing got fixed. But i think it still missed a bug, compiling did not stop.
Anyways i had to reinstall and was lost again, where to start or stop changing with the nodejs stuff.
Finally i can use it on Linux again. Thank you thx1011

Arch Linux sometimes is too bleeding edge for it’s own good :slight_smile:

The atom-editor-bin package packages atom with older self contained versions, and so it works well side by side with the other versions.

Have the same error on Windows 7
Uploading to board using ftdi com port is fine, except it never stops. I have to restart atom to upload a new sketch.

Atom 1.12.2

Uploading using pio on command line works fine: pio run -t upload
I will be using that instead to upload.

Please subscribe to our Twitter or Facebook Redirecting... to be up-to-date with all news.