IDE not loading in VSCode

Hi all,

I’ve got a problem with getting the Platformio IDE loaded in to vscode on my desktop, I’ve had it setup on my laptop for a while so i’m somewhat familiar with the steps to get to working.

Installed VSCode, then extensions > platformio > install.
I now get the options to uninstall or disable the addin so it looks like it’s worked however the alien head icon does not appear in my left toolbar or the bottom status bar, the .platformio folder is never created in my homedir.

I’ve tried uninstalling vscode then manually deleting the left over folders:
%LocalAppData%\Programs\Microsoft VS Code

Then going through the install process again however the result is the same, I can never get the alien head icon to load.

There is a ‘DeprecationWarning: Buffer()’ in my console output but I’m not knowledgeable enough to know if it’s related.

Any assistance much appreciated!

Version: 1.63.2 (user setup)
Commit: 899d46d82c4c95423fb7e10e68eba52050e30ba3
Date: 2021-12-15T09:40:02.816Z
Electron: 13.5.2
Chromium: 91.0.4472.164
Node.js: 14.16.0
OS: Windows_NT x64 10.0.19043


The log saysd “Git installation not found”, but I don’t recall that being a mandatory component for PlatformIO… But it also can’t hurt to install it. Please download it from Git - Downloads, install it and restart VSCode. If it still fails to start, uninstall and reinstall the PlatformIO extension.

Thanks for the suggestion. Initially installing git made no difference but I then did a full re-install of vscode and installed platformio addon. This time it worked properly, the icon was showing in the left toolbar and I now have a .platformio folder.

After closing and re-opening vscode the alien head icon is missing from the toolbar again and the only errors in the console are the DeprecationWarning ones.

I can run ‘pio home’ from a command prompt outside of VScode and it loads in a normal browser window, the IDE just won’t load in vscode!

As any antivirus active that could interfere?

No AV installed, I’ve even tried with defender disabled.

What other extensions do you have installed in VSCode?

C/C++ from Microsoft and PlatformIO.


When re-installing VSC the first extension I load is platformio so it should be a blank slate.

Well that looks pretty good. PlatformIO definitely does not just disable itself after starting up exactly once. I also notice that in this extion view, there is no “x ms” text in the upper right corner of the PIO extension, in contrast to the C/C++ extension. This is the startup-time of the extension. So, PlatformIO didn’t even attempt to start.

Can you click on the cogwheel in the PlatformIO extension and make sure that “Activate only on PlatformIO Project” is disabled so that it will always attempt to start? Restart VSCode thereafter.

I can confirm the option was already disabled.


I’ve just tested loading a platformio project to see if it made any difference but it did not.


Thankyou for suggestions so far!

The only last suggestion I would have is that you try to open a more minimal project like platform-atmelavr/examples/arduino-blink at develop · platformio/platform-atmelavr · GitHub with VSCode (“Open Folder”) and see if it also doesn’t activate.

Other than that, please file an issue in Issues · platformio/platformio-vscode-ide · GitHub for help.

That hasn’t worked, i’ll log my issue over at github. Thanks

I have the same problem. I reinstalled vs code and delted all my extensions but the IDE does not load. Is there any command i can use?