I can't install platfomio in the last version 2.3.0

Hello everyone.
I was using the platformio for 1 week, and everything was perfect.
However, with the new update of version 2.3.0, I can install platformio anymore. ( I tried to install the other version, and I got the same error)
I already tried the GitHub solutions, and it doesn’t work for me.
It seems that is a problem with python somehow, but I don’t how it is even possible…
Thank you all in advance!

I got this message error:

Error: Traceback (most recent call last):
File “C:\Users\pedro.platformio.cache\tmp.piocore-installer-3vzb84mg\tmpp6_6l_vl\pioinstaller.zip\pioinstaller\python.py”, line 170, in find_compatible_pythons
File “C:\Users\pedro.platformio\python3\lib\subprocess.py”, line 420, in check_output
return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
File “C:\Users\pedro.platformio\python3\lib\subprocess.py”, line 524, in run
raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '[‘C:\Users\pedro\AppData\Local\Microsoft\WindowsApps\python3.exe’, ‘C:\Users\pedro\.platformio\.cache\tmp\get-platformio-1.0.0.py’, '–no-shutdo…

Wird, that’s the 3rd topic I’ve seen about this in the last 2 days.

It seems you’re using the Microsoft-provided Python installation. For some people this works after a restart, for some only the Python.org version works.

Have you checked at Windows store python 3.9 not detected · Issue #569 · platformio/platformio-core-installer · GitHub and the related topics?

I’ll check and come back. Thanks

Hey, I checked related problems, and it really seems to be a problem with Microsoft Python. I tried to delete the python 3 in the folder C:\Users\pedro\AppData\Local\Microsoft\WindowsApps, but I got the following message: " Error 0x80070780: The File Cannot Be Accessed by the System".

So I think that Platformio can not access Python 3 in the Microsoft folder as well.

I already installed the web version of python 3, but how can I tell Platformio to stop looking at the Microsoft folder and start looking to another folder in the installation process?

Please open the Windows environment variable editor and make sure that for the “User variables for ” → PATH, the path to the Python.org installed Python comes first, and Microsoft’s version only under that.

The changes need probably a user logout-login to take effect.


Before I logout-login and install python 3.9 I just noticed that the \python37 was already above Microsoft’s version… Then I installed version 3.9, also above Microsoft’s version. But is it right \VS code\bin be under Microsoft’s version?
By the way, What you mean by logout-login? Is it about my Microsoft account? How to do that? (Sorry for so many silly questions, I’m a beginner…)

No just from your Windows account. In the windows start menu it’s called “Abmelden” / “Sign out” in the submenu for the user.


Ah that path is not reveleant, it can stay there at that position.

PS: A reported solved way was to also remove the WindowsApps path from the PATH environment variable (Cannot install PIO · Issue #2413 · platformio/platformio-vscode-ide · GitHub).

You can also try and point VSCode to the direct Python interpeter path in File → Settings → interpeter

with a path like C:\Users\pedro\AppData\Local\Programs\Python\Python39\python3.exe.

Hey. It solved my problem!
In the end, I deleted Windows App from Path, just in case… Seriously, I was having a similar problem with the Arduino IDE because I installed Arduino IDE from Windows Store, so I deleted the Windows Store’s version and installed the .zip version.
Now my paths look like this:

If I got any other problem with deleting the Windows App, I would return here to let everyone know.
But for now, I really appreciate your effort and your time spent with me! I would like to give back someday.

I had the same issue.

My solution was:

In the path C:\Users\XXXX\AppData\Local\Microsoft\WindowsApps there is a FAKE python.exe
file. Really, it is a link to Windows Store where to download and install it. This aspect makes
the installation fails. If you install python from Windows Store or change the path variable to
another location with a good installation of python, it works.

Best regards



This solved it for me! Just downloaded from store and everything worked fine. Thanks!

this work for me.

Solution 1

  1. Press Windows
  2. Start typing: App Execution Aliases
  3. Disable Python and Python3
  4. Restart VSCode.

subprocess.CalledProcessError · Issue #221 · platformio/platformio-core-installer (github.com)