PlatformIO Community

I cannot figure out how to upload a spiffs image

I cannot figure out how to upload a spiffs image. I don’t have an “Upload File System Image” task in any menu.

What steps do I take?

Thanks

What is yor platformio.ini and what is the IDE you are working with?

Does uploading via the command pio run -t uploadfs (see docs) work?

Thanks maxgerhardt
I am running the Arduino platform for esp8266 with a NodeMCU

platform.ini:
[env:nodemcu]
platform = espressif8266
board = nodemcu
framework = arduino

when I run “pio run -t uploadfs” I get the following:

Error: Not a PlatformIO project. platformio.ini file has not been found in current working directory (/home/henry). To initialize new project please use platformio init command

Thanks

You must execute this command within your project fodler. Navigate to it using the cd command of your shell.

Also I’d need to know your OS and your IDE.

ubuntu 16.04
Atom with Platformio
Arduino

As you suggested, I went to the project directory where I had added a data directory with my files to be uploaded. Everything is there, ready to upload.

I ran “pio run -t uploadfs”
and I got:

Building SPIFFS image from ‘data’ directory to .pioenvs/nodemcu/spiffs.bin
/SSIDFile
/query.html
/PassFile
/response.html
/initial.html
/submit.html
Looking for upload port…
Auto-detected: /dev/ttyUSB0
Uploading .pioenvs/nodemcu/spiffs.bin
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed

Is your NodeMCU connected properly to your PC and you don’t have a serial monitor open? Can you put the ESP8266 into bootloader mode (hold down FLASH button, press RESET once while FLASH is being pressed) and retry the upload.

I ran “pio run -t uploadfs” from the terminal built into platformio (Platformio->terminal) and it worked.
Still don’t have the Platformio menu item “Upload File System Image”. Any idea why I don’t.
Otherwise, thanks for your help, I can now up load data files inside of Platformio.

H.

I think when you open the Command Palettte inside Atom and type in “Upload” that menu option should appear. (see https://flight-manual.atom.io/getting-started/sections/atom-basics/)

Yes and “Alt+SHIFT+CMD+F” will do it automatically.
Thanks, it all works great.

H.

I have the same problem - missing “Upload File System Image” option in PlatformIO Pallete (after clicking bottom “PIO Build”) there was allways option “Upload File System Image”, but after I reinstalled my MacOS 10.11 (because HDD fail), and fresh new install Atom + PlatformIO, this option is missing! Please help. The shortcut “alt+shift+cmd+f” don’t work! Only when run shell command “pio run -t uploadfs” this works and do everything correctly as always did the old “Upload File System Image” button…
SW: PlatformIO core 4.3.4 in Atom + platform ESP8266 actual version