How to bring attention to a dying post?

Hello all, I hope you are all doing well.

I wanted to ask about whether or not it was possible to revive a post that seems to not be getting any traction. For example, what if a post is made but no one answers it. And day by day the possibility of someone helping you starts to shrink and shrink. I don’t want to make many posts over and over and become a spammer. But I also know there are people on this community that have done what I am trying to do before, and it wouldn’t be time consuming either.

If you find a post isn’t getting updates, there could be many reasons, one being that no-one who has read it has a clue on how to help! :wink: But seriously, if you find a post not getting an update, perhaps politely adding a reply asking something like "can anyone help me here please? " or similar. You might need to add a few spare words to get the word count over 20 though – that’s the minimum for replies.

Is there a post that is giving you cause for concern?



1 Like

Yes, I made a post about getting some help with setting up an ST-LINKV2 debugger. I just received some help on setting up the small clone version but I already took so much of the user’s time I don’t want to ask again. And I saw a post from Ivan (a platformio team member) showing him using one on these forums, but he doesn’t explain how. So I assuming that people must know how to do this. The only problem is that I barely started diving deep into this sort of topic of microcontrollers, coding, and debugging within the last month.

Ok, thanks. I’m afraid I don’t recall seeing your post, sorry. :cry:

I have a (currently unused) STM32 Nucleo development board, which has the ST-Link device built in. In order to upload a simple Blink sketch, using the Arduino framework, I have this platformio.ini file:

platform = ststm32
board = nucleo_f103rb
framework = arduino

debug_tool = stlink
upload_protocol = stlink

; These next two lines cause a debug build and the
; Nucleo board to be able to be debugged using 
; Alien head->Quick Access->Debug->Start Debugging.
;build_flags = -DCORE_DEBUG_LEVEL=1
;build_type = debug

I am able to upload the following sketch:

#include <Arduino.h>

#define LD2 PA5

// How long to blink for when doing the short blinks.
const uint8_t SHORT_BLINK = 400;

// How long to blink for when doing the long blink.
const uint16_t LONG_BLINK = 1000;

void setup() {
    pinMode(LD2, OUTPUT);

void loop() {
    digitalWrite(LD2, HIGH);
    digitalWrite(LD2, LOW);

I have just attempted to upload this, and it gave me problems at first. But I held down the RESET button until it started the upload, and t worked fine. Just to be sure, I changed the code and uploaded without pressing REST and it “just” worked! I hadn’t changed the program on the board in over three or four years – since before UK lockdown, so around 2019!

If you head over to the docs page and type your board name into the search, it will give you all the options available and show how to set up the platformo.ini file for your board.



1 Like

I really appreciate your response. So my problem is that I am using an ST-LINK/V2 like this:

Which I think is different from the nucleo board. And even when following the debugging documentation for this debugger I still run into errors which aren’t answered by the debugging tutorial page itself.

I have been getting this issue:

And when I look online for a potential answer I am not able to find anything related. I saw Ivan (a platformio team member) make a post where is using it, with the exact same Arduino as me (Arduino DUE) but he has 5 wires connected from board to debugger. Whereas the ‘tutorial’ on setting this up only shows 4. Leading me to believe I am missing something. It’s not his fault at all, as he was merely making a post about how the functionality had been added to PlatformIO. But I am not able to find anything else on setting one of these up.

According to Guide: Connecting your debugger | STM32-base project, and my ST-Link V3, you only need three wires, SWO, SWDIO & SWCLK. Possibly power as well, but that page warns against powering your board from the Clone debuggers as there is usually no protection on the power pins and can fry your board! Power from the USB connector, but never from both!

Usage ST-LINK V2 Tutorial. STM32 Programming for Beginners. Cheap clone ST-Link comparation - YouTube might be useful.

Your error message is the same one I got, well, everything after the line about power being too low, when my board wouldn’t program. That’s when I had to hold the Reset button until the upload started.

I’m wondering about that voltage message though. I searched, st-link v2 "target voltage may be too low" at DuckDuckGo, and there are quite a few hits. Seems thar the V2 isn’t putting out enough power to keep the board in debug! Have a look and see what you think.



I’m not too sure on the ST-Link clones, but the behavior on the “3.3V” pin on them should be that they first try and read the voltage on that pin, so if the device is externally powered, they will notice that and read the target voltage, and if it’s low, they will output 3.3V on that pin to try and power the target.

If that doesn’t work however, double-powering a device through two power sources can be deadly, as small differences in voltages can lead to huge current flows. If you want to play it safe, take a large-value resistor like 10 kOhm and connected in between the 3.3V pin of the STLink and the 3.3V pin of your target device.

1 Like

Guys, ST-Links (original ones, not clones) have a T_VCC pin, meaning “target VCC”. You connect it to your device’s VCC bus, and it is an input to the ST-Link so it knows the voltage your device is using.

The error you’re getting means the target voltage can’t be detected by the ST-Link, so either the T_VCC is not connected, or the device is not powered…


My understanding is that the ST-Links want T_VCC as an input, and never power the device. The clones I’ve used (and I’ve stopped using them since an ST-Link V3 Mini costs less than EUR 15) have all provided power on the VCC pin, and don’t care if its connected or not… So there’s a difference there in how you use clones compared to original ST-Link devices.