PlatformIO Community

How do I update a registered library?


#1

Added library asyncHTTPrequest a few days ago. Version 1.0.0. As advertised, it took about 24 hours to appear.

I have updated the library and so changed the version in library.json to 1.1.0. No other changes to library.json. It checks out as valid json with jsonlint.

After 24 hours without updating, I tried to register again, but get a message saying the name, keywords and description are missing. They are the same as when it was first registered.

Could someone give me some pointers as to how to accomplish this?

Update: New version is now available. It just seems to have taken a long time. Oddly, the time indicated for updating the version was 5 hours earlier than this original post, when the new version was not yet available.


#2

Looks like you are more lucky than me.
I have the same problem (Recurring problem: my library update from github does not show up on PlatformIO) for some days now.
I can see your lib 1.1.0.
Mine, though days older, is still not available.


#3

Sorry, we found a bug in our Library Crawler which “froze” updates queue :frowning:
Now all should work.


#4

Hi,

I have updated my library for 4 days, pushed a few commits but it is still old. Maybe it is the same issue as the fellows above. #id 5497 #name Ultrasonic-HC-SR04

I thank you for the attention.