How do I disable pio in a vscode project?

Platformio is enabled in my vscode projects that don’t use it. How do I specify whether pio should be enabled in a project? The presence of the pio ini file would seem to be a good trigger.

There is an option in VSCode to only show the PlatformIO toolbars and icons etc, when the ini file exists.

I’m not at my laptop just now, sorry, but if you open the preferences and search for PlatformIO.ini it should appear. I use that option myself.


Thanks. I didn’t think to look in vscode preferences.

I assume you are talking about vscode preferences brought up with ctrl-alt-P. I looked there and found a ton of platformio results but none that looked appropriate. Can you be more specific.

Duh, it was preferences not ctrl-alt-P but ctrl-,.

Sounds like you found it!