PlatformIO Community

Home Screen doesnt load

So whenever I start the IDE the home window does pop up normally, but it doesnt really load. I cant open new projects because I cant choose a board, I cant access the librarys properly (that could be smth else as well tho, I am not sure. Error code: The file “Source” can not be opened: “Arduino.h”. I google translated it, so it may sound slightly different.). Once I fully restart the IDE it works again, but as soon as I fiddle with the workspace, it is gone again. I already tried what I could find about it here, restarting and reistalling everything, I would be glad about any help. Also, it happens on both of my pcs. They both also have C Lion, and are windows 10, if thats any help. Here a screenshot of the Loading stuff.

So this is happening on Windows 10, with CLion? Is there any network proxy involved? Is you firewall blocking any internet lookups?

My firewall should not do that. Both pcs do have norton, so maybe thats worth looking into. What protocolls does PIO use? Also, I dont know if there is any relation to Clion, I just noticed that different IDEs often conflict in some way.

Ah, so this was with VSCode then, AND they also have CLion?

If the code compiles fine, but the error comes and goes… it’s likely that IntelliSense is being it’s usual stupid self. I have heard that versions past 0.26.0 have had some issues, but haven’t had issues myself (fingers crossed I didn’t just jinx it).

As far as the loading issue… sometimes PIO Home is just a little slow the first time… but if it takes more than 20 seconds… you’re waiting too long, or it’s not going to happen. If you wanted to test the firewall/AV, I’d disable it for a minute, and see if anything changes… but I don’t think it needs anything special. Then again… I have just started using Bitdefender on my Windoze box… and it has been a bit over-eager at blocking things, and asking questions never… so at least some of the AV packages are getting at bit too ‘user friendly’. :-/

Honestly I doubt that its my firewall, because norton is pretty popular. I would have at least found that issue with other people if nothing else. I didnt change settings of it at all. Also, Coding works just fine it seems, so I let it load in the background, as long as I dont have to create new projects. Even after 20 mins nothing happened, its just not loading at all. Its just annoying. Would be nice if there was a solution or a fix, but yeah, I can still use it anyway.