Help, Python seems to have fallen on MacOS and it can't get up

I’ve been using PlatformIO for a while to develop Arduino code in VS code, including Marlin for my 3d printer. That WAS working, but I haven’t tried to update Marlin for a while, and I just ran into issues when trying to also use it for Autodesk Fusion 360 scripts and add-ins.

I now seem to have something badly wrong with the installation of python between Fusion, VS Code and platform IO. I’m seeing complaints in VS Code about not having python for, but running scripts and extensions seemed to be working until just now. Now I just created. a new script and when I run it it says it can’t find the adsk module.

Note that PlatformIO installer seems to be hung installing PlatformIO.core

I don’t know if platformIO is needed for Fusion, but as I mentioned before it’s there for Arduino an Marlin.

I seem to have quite a few Pythons installed typing python in terminal and hitting code shows:
% python
python python2 python2.7-config pythonw
python-config python2.7 python3 pythonw2.7

All of these are in /usr/bin
% which python
% ls /usr/bin/py*
/usr/bin/pydoc /usr/bin/python2 /usr/bin/pythonw
/usr/bin/pydoc2.7 /usr/bin/python2.7 /usr/bin/pythonw2.7
/usr/bin/python /usr/bin/python2.7-config
/usr/bin/python-config /usr/bin/python3

Personally I like to use Homebrew to install development tools.

Any advice on how to straighten this all out.

The first thing I’d recommend is just a clean uninstall and reinstall of PlatformIO. Remove the PlatformIO extension from VSCode, close VSCode, remove the entire /Users/<user>/.platformio folder, restart VSCode, add back the PlatformIO extension and let it install. Does that not go through?