Good 'old includePath error and can't open source file "stdint.h" in new projects

Hi everyone,

I’m really trying to get on the platformIO boat as a replacement of Arduino IDE, which is lacking in all “modern” tools we need. So i installed the mac version of Vscode and got the 2 extensions platformIO and C/C++ Intellisense from microsoft.

I am struggling with an error that seems common, even 2 years ago, but nothing I’ve read and tried worked. It is the includePath error, in a fresh new project. I have it in all my new projects (tests one and the “real one”) and working with “3 errors” is really bothersome to be honest.

Building works fine though. But it defeats the purpose of a good IDE to work with “3 errors” all the time :confused: .

What are the solutions in 2021 ? I can’t imagine it hasn’t been fixed since 2018, so I imagine it might be because I’m on Mac ?

I tried reverting the microsoft intellisense to 0.26.0 for example, desinstalling and reinstalling platformIO while doing so, updated my python3, normally i have everything up to date.

I do believe I have to change something in my c_cpp_properties.json, but I just know with what. I’m a little lost, as I don’t understand what is going on.

Does that problem been found out ?
Any help would be greatly appreciated :slight_smile:


No, the file is automatically generated by PlatformIO, do not edit it manually. If necessary, command a rebuild of the file with Command+Shift+P → Rebuild IntelliSense.

Does the project build? If not, there’s an issue with the toolchain and/or compiler package. If yes, do an IntelliSense rebuild.

Hi max, thanks for the reply.

Yes, the project build, it even uploads and works on the arduino.

Rebuilding Intellisense gave me 5 new errors : “Comments are not permitted in JSON.” for the c_cpp_properties.json which is automatically generated, as you said. :cry:

I’ll try to install it on Windows to see if the error is still there.

Alright, VScode and platformIO on Windows is working fine without those errors on a new project I just made.

I guess it’s related to the MacOS version then. Anyone knows something about that ?

Do you have the same, up-to-date VSCode version installed in Mac as you have on Windows? Have you tried removing all extensions except C/C++ by Microsoft and PlatformIO?

Alright, it seems to be OK now…

But I don’t really know why though. :sweat_smile:
My best guess is that I changed the way I link my project to my git Repo so that I can use the platformIO “Create new project” tool. Or maybe because it is a brand new project (the test one was 2 months old, not that old though).

I was totally up-to-date (first thing I did).
PlatformIO 5.1.1 on Mac & W10
VsCode last version re-downloaded on Mac, and is up to date on W10
I’ve disabled all C/C++ extensions as I read I can mess up the IntelliSense.

I have to admit, this morning I did turn off one setting in settings.json :
C_Cpp: Error Squiggles
turned to disabled, of course no more errors… :sweat_smile:
but it felt a bit like pushing the dust under the carpet, you know.
So I turned it back to Enabled If Includes Resolve, aaaaaaand still ok !

I tried to disable all extensions but the 2 essentials, reactivating them one by one. It did come back once, disabled reenable “git history” thinking i got the problematic one. It didn’t showed up after re-enabling. Ugh.

But still, it’s not there anymore so I can work at ease now ! Don’t really like when “magic” solves things, but at it is not essential, I’ll settle for that. Maybe I didn’t rebuild the IntelliSense enough, dunno.
I’ve seen that error many times without solutions. The problem seemed to vanish, maybe, like mine. Maybe it’s a matter of constructing the Intellisense…

Thanks a lot for your help :slight_smile:

edit : i unchecked the solution as it’s random… honestly i already invested too much time before posting a message, for a random behavior…

Update :
it comes and go as you build, sometime it’s an error, sometimes it’s not… didn’t knew my PC was upgraded to a quantic core…

Possible interference by Antivirus system?

Same problem here but on a STM8 board, on Mac. Compiling is fine, just IntelliSense not working for some std* headers. I could locate them in the PIO framework folder, but these paths just don’t appear in c_cpp_properties.json.

That is due to VSCode not recongizing SDCC as a compiler, though. As reported in here and here.

Alright thanks for your efforts and the answer it really seems to be that case