Git repo clone - includePath

Hey everyone,
New over here so I hope I’m doing everything right -
I have started using github to sync my codes from desktop to laptop.
I cloned my repos using VSCode Git console and then used pio “import project” and choose the board i’m using. for some reason all the libraries are not included -
The libraries are installed on my laptop (as you can see even arduino.h is not loading).
Would love your help!

Have you tried building the code yet? If the required platform/framework files/libraries haven’t been installed on your second machine yet, they’ll be installed when run the build. After that, the errors should go away.

Otherwise, can you share a link to the gihub repo and also a compile log so we can see what sort of build errors you get?

Yes, I have tried building the code and the problem persists.
All of the libraries are installed on the second machine (Arduino.h obviously…)
My Project Github Repo
What’s the way to compile a log? Do you mean copying the build terminal output?

EDIT: Just reminds that the code works perfectly on the original machine that I worked on. Any chance it has something to do with c_cpp_properties file?

Yup, that’s it. Don’t worry about that for now though unless you still have issues after reading this.

That’s a good start :wink: No, c_cpp_properties.json is automatically generated by platformio and has machine specific paths, hence why it is actually in the .gitignore file so it doesn’t get transfered and clutter up commit logs.

Your project built for me after adding

lib_deps = 

to the platformio.ini so that the Blynk library was installed, and since you’re using the RTC widget it needs the Time library also. After that, the red squiggles all went away for me. If it doesn’t for you, try removing the project folder from the VScode workspace (right click on the folder in the VSCode sidebar ‘Remove Folder from Workspace’ and then go File → Add Folder to Workspace to add it again… that might liven it up.