GIT library download


I have Platformio core 5.0.2 installed.
I tried to reference github libraries in platformio.ini in different ways.

I always get the following UserSideException during compiling.

Library Manager: Installing git+
UserSideException: Please install Git client from

I Installed git version 2.29.2. I tried the x32 and/or x64.
Nothing helps.

Does anybody have an idea bout this?
Thanks in advance.

I see that you have installed the git client. Is it on your system’s PATH? If not, you will need to add it. After adding it, any existing open applications will not see it, they will need to be restarted. VSCode, for example, will need to be restarted after adding git to the PATH. When an application loads, it copies the environment at that time. Changing the environment outside of the application will not affect it.



1 Like

Hi Norman
Thanks for the hint, I checked the Windows environment variable PATH.
“C:\Program Files\Git\cmd” is listed there.
Git files exist in that path too. It looks all ok to me.
That doesn’t seem to be the cause.
Any other ideas?

Additional Information…
I get a bunch of subsequent errors after that error message:

UserSideException: Please install Git client from
File “C:\users\lappi.platformio\penv\lib\site-packages\platformio\builder\”, line 170:
File “C:\Users\Lappi.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Script\”, line 598:
return _SConscript(self.fs, *files, **subst_kw)
File “C:\Users\Lappi.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Script\”, line 287:
exec(compile(scriptdata, scriptname, ‘exec’), call_stack[-1].globals)

I checked the path for python too.
"C:\Users\Lappi\AppData\Local\Programs\Python\Python39\Scripts" and
Those are in the Accounts PATH, not in the System PATH.
Python exists in those Paths.

Can it be there is some Trouble with python?
Version 3.9.0 is installed.



Open a terminal (Windows + R -> cmd.exe) and execute git --version. What does it return?

It gives
git version

Try to log out and log back into the Windows account, or better, reboot the computer – seems to me like the environment changes have just not been propagated to VSCode properly.

I rebooted it before already. I just rebooted again. Still the same.

Open a PIO terminal and again execute git --version. What does it return?

Git is not beeing recognized there.

PS D:\Daten\Dropbox\uC\VSC_Workspace\Uhr_55> git --version
git : Die Benennung "git" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms 
erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.    
In Zeile:1 Zeichen:1
+ git --version
+ ~~~
    + CategoryInfo          : ObjectNotFound: (git:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

Eh… interesting… Never seen that one before. Try a few things:

  • In VSCode, go to File -> Preferences -> Settings and search for “git path”. There will be a “Edit in settings.json” button which takes you to the configuration file. Put the direct path to your git.exe executable in there (and remember to escape a backslash with a backslash, as in C:\\Program Files\\git\\cmd\\git.exe, for example)
  • restart VSCode and see if git is now being recognized in the PIO terminal
  • if not, uninstall the PlatformIO VSCode extension in the extension side, reinstall it and restart VSCode – does it work now?

The path modification didn’t help.
The reinstallation of platformio helped. It recognizes the command after that with “git --version” and returns “git version”.
I reset the path to “” again and it still finds git. So the path wasn’t the cause obviously.

I finds the libraries and installs them now:

Library Manager: Installing git+
git version
Cloning into ‘C:\Users\Lappi.platformio.cache\tmp\pkg-installing-lpcmkziw’…
Library Manager: MCP23S17 @ 2018.9.24+sha.842f9d7 has been installed!
Library Manager: Installing git+
git version
Cloning into ‘C:\Users\Lappi.platformio.cache\tmp\pkg-installing-l994j5rs’…
Library Manager: Adafruit_SH1106 @ 0.0.0+20201108154149.sha.f4e427f has been installed!

Gosh that was a weird one. :crazy_face: :roll_eyes:

Thanks a lot.

By the way. I have a second PC with the same behaviour.
It seems systemic therefore or i did the same on both machines to have the same effect.
I will try that trick there too.

My guess is that PlatformIO checks for the git executable path only at installation time once; this would explain why a re-install helps to suddenly find git again. Maybe @ivankravets can cross-check this.

OK. Sounds plausible.
Thanks a lot for your help.

Python 3.9? I think there’s a problem with that newest version. Unless if course, VSCode is using python supplied with PlatformIO.


No, it does not. We just call git and it should be visible in the system PATH. There is an issue with Windows, sometimes you need to restart the application or OS to take a new path into effect.

1 Like

Seems to be at least buggy then because he said re booted already :S

I just rebooted pc after installing git, and I now it works.
I can download libraries from git.