Frightening Event When Joining platformio Community

I’m running Windows 10 1607 Enterprise, Bitlocker enabled, on a Dell Core i5 computer, with Google Chrome configured as the default browser.

After signing up for the platformio community, I was notified that a verification email would be sent to me. I had signed up using my gmail account, so I opened a new tab in Chrome and accessed gmail. The verification email was in my inbox, so i clicked the link to verify my address. The community’s web page opened with the “Your first notification” message.

Immediately, my monitors flashed twice, something appeared and disappeared on one of them that I wasn’t able to catch, and, two seconds later, I got a notification from Windows that Bitlocker had been disabled. I immediately re-enabled Bitlocker, uninstalled Visual Studio code (the platform upon which I had tried and failed to install platformio, but that’s a separate issue), and did a System Restore back to Sunday, when I had installed the latest Windows Updates (yeah, I know: I should always wait at least a month, but there had been no complaints from anyone about the updates for 1607).

Upon restart, I received a STOP: 0xc000021a. Upon restarting to the F8 boot options, the system informed me that “A required device isn’t connected or can’t be accessed. Error code: 0xc000000f”.

My Bitlockered drive is toast, and Windows refuses to boot into either normal or Safe mode.

The only other interesting thing I had done today was try (and fail; it can’t actually be installed on Windows, as noted in on its github issues pages) to install Sming (I’m evaluating microcontroller development environments). However, Sming doesn’t really install anything that’s hooked into the OS. I then tried to install platformio, after installing Visual Studio code. When I installed the platformio extension, the “Home” icon did not appear on the toolbar as described in the instructions, so I closed VS and reopened it. VS immediately installed the April update for Visual C/C++ and then tried to install platformio, which failed with an error that it had tried to make an illegal call to Visual C.

That’s when I decide to join this community and ask for help, and that is when my real troubles began.

I don’t know what disabled Bitlocker. I’m not going to do any forensics on the drive. I’m simply going to throw the hard drive away (after physically destroying it, of course) and start all over again. But Bitlocker was disabled IMMEDIATELY after the platformio community’s “Welcome - your first notification” page opened after I clicked the verification link in the email message I got.

I hope this helps someone, but it’s doubtful that I’ll be back this way soon. Once I’ve been stung, I stay out of the neighborhood in which the wasps stung me, even if those wasps may have flown in from some other neighborhood.