error when verifying blink sketch for Bluepill

I’ve created a project with just the blink sketch to use as a base for testing board connectivity. I’ve listed the Uno R3, Uno R4 Minima, and Bluepill F103C8 boards to test. I’m able to successfully verify for both of the Uno boards, but getting a error with the Bluepill and can’t figure out why. I’ve seen many comments about spaces or non-ASCII characters in the path, but I have neither and the Uno worked just fine. Any suggestions or more info needed?

This is what is listed in my platformio.ini file:

description = Test to blink on-board LED at specified interval to ensure proper communication with test board.

platform = atmelavr
board = uno
framework = arduino

platform = renesas-ra
board = uno_r4_minima
framework = arduino

platform = ststm32
board = bluepill_f103c8
framework = arduino

Duplicate of Building to WeAct Blackpill STM32 F411CE Board - #2 by maxgerhardt

Thanks so much to the quick response on this! I made the recommended edit to comment out line 342 in the python script and the verification worked.

That is one post I never came across and seems like a recent issue as well.