sunch file or directory

Hi guys. I am trying to build the marlin firmware for my esp32s2 3d printer motherborad. However, there is an error occured.
屏幕截图 2023-02-28 084941
I uninstall the platform of esp32. And install another version(eg 3.0.0, 4.2.0). But it doesn’t work at all. The same error occurs.
I got the firmware from another BBS. Strange, the firmware can be build last time. And it can work well on my board now. So I think the firmware itself is no problem.
Can anyone helps me? Thanks a lot!

Maybe the non-ASCII characters after D:/ are a problem. Can you change the folder name?


That’s it. I copy my project to the root folder. And I compile it successful. Thank you maxgerhardt.

Hello Sakihata, could you tell me where you got the version of Marlin for ESP32S2?

Thank you

Hello Joseantoniomg. I wonder if you can understand Chinese. Actually, I get these firmware from bilibili website. The author modify the 2.0.9 marlin firmware and make it run on the ESP32-S2. You can click the link below to get more information.
(Hope my terrible English won’t confuse you cause I am an English beginner.)
(开源)ESP32S2 3D打印机主板,支持双Z双限位,支持显示屏控制,支持网页控制,不需要扩展芯片,性能不受影响
Let me translate it for you. (Opensourse) ESP32S2 3D printer board, which support two endstops for the Z axis, and it support 12864 screen controller and website controller. And there is no need to use IO expander (like 74hct595), which improve its performance to drive the stepper motor. (When you use esp32 with 74hct595, 3d printer usually is limited at a low speed. And esp32s2 has more IOs than esp32, there is no need to use IO expanders. So the problem is solved.)