Failed to launch gdb .point 11

first, I noticed that some other people complain from the same problem of mine and I tried to follow the replies but it didn’t help me to resolve my problem, so I created another thread.
Anyway, I’m using nodeMCU so i’m using the nodeMCU for programming while the PlatformIO debugger for debugging. and i’m able to download the flashing program and the LED is blinking properly (but I have to unplug the PlatformIO debugger to be able to download the binary file) but i had no luck to run the debugger and i’m getting the below errors.

Platform-IO error2

and the content of the platformio.ini is:

[env:esp wrover kit]
platform = espressif32
framework = arduino
board = esp32dev
monitor_speed = 115200
build_flags =
upload_port = COM9
monitor_port = COM9
debug_tool = esp-prog
debug_init_break = tbreak setup
debug_speed = 500

Have you gone into Zadig to load libusb drivers for one interface? (article).

Thank you very much, it is working right now!

but I already used Zadig tool before sending this post but it sounds that it didn’t define the USB driver properly, so I tried Automatic USB driver installer for FTDI and LibUSB drivers (
and it did the job