Failed to intialize a PlatformIO Project

Good Morning,

I’m trying to create a new project for arduino due and i receiving this message:

Error: [12/08/16 10:31:31] Processing due (platform: atmelsam, board: due, framework: arduino)

Verbose mode can be enabled via -v, --verbose option

Collected 22 compatible libraries

Looking for dependencies…

Project does not have dependencies

TypeError: sequence item 1: expected string, int found:

File “C:\users\ioanni~1\atom~1\packages\platfo~1\penv\lib\site-packages\platformio\builder\”, line 149:

print json.dumps(env.DumpIDEData())

File “C:\Users\Ioannis K.platformio\packages\tool-scons\script..\engine\SCons\”, line 224:

return self.method(*nargs, **kwargs)

File “C:\users\ioanni~1\atom~1\packages\platfo~1\penv\lib\site-packages\platformio\builder\tools\”, line 247:

“defines”: get_defines(env_),

File “C:\users\ioanni~1\atom~1\packages\platfo~1\penv\lib\site-packages\platformio\builder\tools\”, line 232:

item = “=”.join(item)

[ERROR] Took 5.46 seconds

I tried to update the software and it still don’t works
I tried a google search but i didn’t found something about my case.
Any ideas here?


Please upgrade PlatformIO Core via Menu: PlatformIO > Upgrade PlatformIO Core and restart Atom.

Thank you very much.
Please flag this as solved