Failed to Install PlatformIO v2.3.0 on VS Code v1.54.3

When trying to install the extension on Windows 10, the following error occurs:

Has anyone solved this?

Error: Traceback (most recent call last):
  File "C:\Users\leand\.platformio\.cache\tmp\.piocore-installer-2lc81crs\tmpmmpi36v_\\pioinstaller\", line 170, in find_compatible_pythons
  File "C:\Users\leand\.platformio\python3\lib\", line 424, in check_output
    return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
  File "C:\Users\leand\.platformio\python3\lib\", line 528, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['C:\\Users\\leand\\AppData\\Local\\Microsoft\\WindowsApps\\python3.exe', 'C:\\Users\\leand\\.platformio\\.cache\\tmp\\', '--no-shutdo...

Microsoft’s fake python3.exe, which just opens a window to their app store, is interefering here.

See topics

1 Like

It worked!! The problem really was with the fake version of Windows python. I followed the steps of the links sent and everything is working now. Thank you very much!