Failed to install PlatformIO IDE New

Any help?

I tried the github solutions but no luck with that.

Version: 1.53.2 (user setup)
Commit: 622cb03f7e070a9670c94bae1a45d78d7181fbd4
Date: 2021-02-11T11:48:04.245Z
Electron: 11.2.1
Chrome: 87.0.4280.141
Node.js: 12.18.3
OS: Windows_NT x64 10.0.18363

Error: Traceback (most recent call last):
File “C:.platformio.cache\tmp.piocore-installer-dbh6mhef\tmpgqrwlwdc\\pioinstaller\”, line 170, in find_compatible_pythons
File “C:.platformio\python3\lib\”, line 420, in check_output
return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
File “C:.platformio\python3\lib\”, line 524, in run
raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command ‘[‘C:\Users\Andr�\AppData\Local\Microsoft\WindowsApps\python3.exe’, ‘C:\.platformio\.cache\tmp\’, ‘–no-shutdown-piohome’, ‘check’, ‘python’]’ returned non-zero…

Hmm maybe it doesn’t work well with the Microsoft-installed Python version there.

What happends when you manually open a commandline and execute

C:\Users\Andre\AppData\Local\Microsoft\WindowsApps\python3.exe "C:\.platformio\.cache\tmp\" --no-shutdown-piohome check python’]

(while using the correct username which got corrupted in your post above).

However also the path

Doesn’t look right… .platformio directly in the C: drive root is weird. It’s expected in the C:\Users\<user>\.platformio directory. You aren’t running VSCode as root are you?

Can you quickly reference what solutions you’ve tried from the Github?

Hi !
I got the same issue, I installed Python using python website, add Python to path, but when using cmd and write “python”, it open me " Windows Store " . So I clicked on "Get it " on Microsoft Store, and then it worked…

Absolutely can’t understand why … but now it works


If it’s still not found after a Python installation you either

  • have not yet restarted your computer or re-logged into your account to make sure changes to the PATH are visible to alle programs
  • possibly deactivated the option to add Python to the PATH in the installater

In another topic it is reported that the Python version distributed on the official website must be used, not Microsoft’s one (Invalid path to Python Interpreter - #5 by maxgerhardt).

1 Like

Computer was restarted, and python was both added manually and by the installater. In both case, platformio won’t install. I download Python via the official Web.

Microsoft’s one succed to install Platformio … quite strange I have to admit, but now it’s working :slight_smile:


Thank you very much @ julien.vincenti0, I had the same problem as you. When using Python from the Windows Store the problem was solved.

Python from python website seems to install python.exe that is nicely in the path. Put this script is calling python3 which does not exist in windows python website installation.