Fail to install VSC+Platformio IDE on Windows 8.1


#1

Yesterday, strictly according to the instructions “http://docs.platformio.org/en/latest/ide/vscode.html#installation” downloaded Visual Studio Code, added “platformio-ide”, received an account. After some autoinstallations, I can see on the home page an endless indicator of loading Recent News, although the link to Twitter opens. I apply the screen.

But it is no problem, it is the information, possibly related to the problem. Next, following the instructions, I click New Project, enter its name Hello_World, Arduino Nano Atmega328, the rest by default, press Finish and watch the Wizard with Please Wait … for more than an hour.

I rebooted Windows 8.1, the same thing for 3 hours. At the same time in the task manager, VSC does not have any CPU activity (if its window is minimized), not even network / disk. Tried again today with the same result - there is no error’s reports and no progress.

What to do to identify the cause of the problem?


#2

When I click on Finish button to create new project, the following message appears in the log:

workbench.main.js:sourcemap:3542 [Embedded Page] [react-ga]
workbench.main.js:sourcemap:3542 [Embedded Page] Uncaught TypeError: Cannot read property ‘endsWith’ of null


#3
  1. Did you block Twitter IP?
  2. Please run VSCode > Tasks > Run Task… > PlatformIO: Update packages, libraries…

It should remove cache. Restart VSCode.


#4
  1. Never.
  2. There only hint at righ bottom corner “Tasks are only available on a workspace folder.” and no more. Manually reinstall platformio addon - no changes.

#5

I’ll try to install everything inside VMWare to understand what the problem is. I will write off afterwards about the results.


#6

The problem was caused by using characters outside the Latin alphabet in the MS Windows account. This is a bug of VSCode itself.


#7

That was our bug and we have fixed it in the recent PIO Plus Core v1.4.3. Please open PIO IDE Terminal, type pio update, restart VSCode. Everything should work now. Sorry for the issue.


#8

Yes, thanks - I confirm everything’s fine