PlatformIO Community

Execute build always reverts to windos CMD

envir: Windows fresh install visual code / platformIO c++
First build occured i think using powershell seemed ok (no way to verify anything)
Second restart of PLatform IP
platform IO wants to start BUILD using CMD windows (no way to alter???)

THis is impossible since my files are on a shared folder (and will always be)

is comokains usiging::::
The terminal shell CWD “\\octopus\archive\Devlo\First1” does not exist

 PLease remark  tripple   back slash and singel backslash  MIXED

settings.json
“terminal.integrated.cwd”: “c:\archive\DEVLO\”, (using link to sharable (ESSENTIAL))
“terminal.integrated.shell.windows”: “C:\WINDOWS\System32\WindowsPowerShell\v1.0\powershell.exe”,

Tried everything to make the build behave, but only after complete reinstall (weerks retrying!)
it works ONCE to fail after the forst refresh/restart of visual code

HOW can I FORCE for all BUILD to use powershell

Please help, im desperate, all microsteps like these are NOT explained , just losing time …
There seems for everry single option a need to reinstall everything and 10 ways but non of them all work…

PS: .

THanks in advance

That looks more to be a VSCode issue. I get the same type of error if I change my default terminal to Powershell, and try to compile a network shared project.

image

But if I mount \\rockpro64\public to a drive letter, and then work from that, everything works fine.

I agree one has this problem in vscode

Solution:
“terminal.integrated.cwd”: “c:\archive\develop\”,
“terminal.integrated.shell.windows”: “C:\WINDOWS\System32\WindowsPowerShell\v1.0\powershell.exe”,

or use git /bash sh (in windows)

In platform IO it runs once then reverts to using cmd windows (Windows XP problem in 2020)

please is there a setting to alter cmd in platformIO